Bug 191565 - REGRESSION: [ MacOS Debug ] Layout Test imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html is flaky timeout
Summary: REGRESSION: [ MacOS Debug ] Layout Test imported/w3c/web-platform-tests/css/m...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-11-12 14:58 PST by Truitt Savell
Modified: 2021-05-07 14:59 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2018-11-12 14:58:40 PST
The following layout test is flaky on MacOS Debug

imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html

Probable cause:

This test has become far more flakey than before and is timing out at around 80 seconds. Otherwise passes at around 30 seconds. We may need to mark test as slow for now until a solution is found. Needs to be reproduced. 

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=imported%2Fw3c%2Fweb-platform-tests%2Fcss%2Fmediaqueries%2Ftest_media_queries.html
Comment 1 Radar WebKit Bug Importer 2018-11-12 14:59:15 PST
<rdar://problem/46004898>
Comment 2 Truitt Savell 2018-12-05 14:19:10 PST
I have been unable to reproduce this failure locally. I have been trying to reproduce using command:

run-webkit-tests --root debug-238908 imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html --iterations 500 -f --debug

This tests seems to run a lot of sub tests and may be slowing down due to other factors during the test runner.
Comment 3 Truitt Savell 2018-12-06 08:49:51 PST
marked test as slow in https://trac.webkit.org/changeset/238932/webkit to see if more time will allow the test to pass on the bots.
Comment 4 Truitt Savell 2018-12-07 08:18:14 PST
it appears marking test as slow has brought this test back to green. no timeout has occurred in the lats 15 runs on any platform. Marking bug as resolved.