Bug 191491 - REGRESSION (r238047): [iOS] Layout tests with input type="password" failing
Summary: REGRESSION (r238047): [iOS] Layout tests with input type="password" failing
Status: RESOLVED DUPLICATE of bug 190565
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-09 15:41 PST by Ryan Haddad
Modified: 2018-11-10 08:43 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-11-09 15:41:26 PST
The following layout tests are failing on iOS Simulator after "[iOS] Draw caps lock indicator in password fields" - https://trac.webkit.org/changeset/238047

Regressions: Unexpected text-only failures (8)
  accessibility/ios-simulator/form-control-validation-message.html [ Failure ]
  fast/css/text-overflow-input.html [ Failure ]
  fast/forms/basic-inputs.html [ Failure ]
  fast/forms/input-appearance-height.html [ Failure ]
  fast/forms/input-value.html [ Failure ]
  fast/forms/placeholder-pseudo-style.html [ Failure ]
  imported/w3c/web-platform-tests/xhr/event-upload-progress.htm [ Failure ]
  tables/mozilla_expected_failures/bugs/bug92647-1.html [ Failure ]

https://build.webkit.org/results/Apple%20iOS%2012%20Simulator%20Release%20WK2%20(Tests)/r238048%20(865)/results.html
Comment 1 Ryan Haddad 2018-11-09 16:09:54 PST
The imported/w3c/web-platform-tests/xhr/event-upload-progress.htm failure is unrelated, but the rest of the tests have similar diffs:

--- /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/fast/forms/placeholder-pseudo-style-expected.txt
+++ /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/fast/forms/placeholder-pseudo-style-actual.txt
@@ -17,6 +17,8 @@
       RenderText {#text} at (282,21) size 5x19
         text run at (282,21) width 5: " "
       RenderTextControl {INPUT} at (288,22) size 137x22 [bgcolor=#FFFFFF] [border: (1px solid #4C4C4C)]
+        RenderFlexibleBox {DIV} at (6,3) size 123x15
+          RenderBlock {DIV} at (0,0) size 123x14
       RenderText {#text} at (426,21) size 5x19
         text run at (426,21) width 5: " "
       RenderText {#text} at (569,21) size 5x19
@@ -43,7 +45,7 @@
     RenderText {#text} at (0,0) size 48x14
       text run at (0,0) width 48: "password"
 layer at (303,33) size 122x14
-  RenderBlock {DIV} at (6,3) size 123x15
+  RenderBlock {DIV} at (0,0) size 123x14
 layer at (590,33) size 122x14
   RenderBlock {DIV} at (6,3) size 123x15 [color=#A9A9A9]
     RenderText {#text} at (0,0) size 34x14
Comment 2 Ryan Haddad 2018-11-09 17:31:14 PST
These may just be rebaselines, but I'm not certain. Since this affects EWS, I'm going to roll out the change.
Comment 3 Ryan Haddad 2018-11-10 08:43:45 PST

*** This bug has been marked as a duplicate of bug 190565 ***