Bug 190627 - Some WK1 repaint tests are flakey
Summary: Some WK1 repaint tests are flakey
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 189752 189841 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-16 10:18 PDT by Simon Fraser (smfr)
Modified: 2019-05-11 16:34 PDT (History)
9 users (show)

See Also:


Attachments
Patch (3.82 KB, patch)
2018-11-07 00:39 PST, Simon Fraser (smfr)
zalan: review+
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.34 MB, application/zip)
2018-11-07 02:24 PST, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2018-10-16 10:18:17 PDT
compositing/repaint/iframes/compositing-iframe-scroll-repaint.html is flakey (maybe only with the patch from bug 90342).

When it breaks, the compositing layer already has a repaint, so in GraphicsLayerCA::setNeedsDisplayInRect() the dirty rects already contain the rect and we bail.

This suggests that testRunner.displayAndTrackRepaints() isn't triggering paints in all compositing layers in WK1; need to see if we're flushing layers at all in that code path.
Comment 1 Radar WebKit Bug Importer 2018-10-22 14:22:49 PDT
<rdar://problem/45466143>
Comment 2 Dawei Fenton (:realdawei) 2018-10-22 15:05:17 PDT
The following tests were marked flaky in Mojave WK1

compositing/masks/compositing-clip-path-change-no-repaint.html
compositing/repaint/iframes/compositing-iframe-scroll-repaint.html
compositing/repaint/iframes/compositing-iframe-with-fixed-background-doc-repaint.html

revision: https://trac.webkit.org/changeset/237333/webkit
Comment 3 Simon Fraser (smfr) 2018-11-04 09:58:30 PST
It looks like we never get a -viewWillDraw after the load event and before zero-delay timers, which is controlled by whether runloop observers fire at that time; they may not if there is no idle phase in the runloop.
Comment 4 Simon Fraser (smfr) 2018-11-07 00:39:42 PST
Created attachment 354069 [details]
Patch
Comment 5 EWS Watchlist 2018-11-07 02:24:18 PST
Comment on attachment 354069 [details]
Patch

Attachment 354069 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/9891094

New failing tests:
compositing/columns/composited-rl-paginated-repaint.html
compositing/repaint/repaint-on-layer-grouping-change.html
compositing/columns/composited-lr-paginated-repaint.html
Comment 6 EWS Watchlist 2018-11-07 02:24:20 PST
Created attachment 354077 [details]
Archive of layout-test-results from ews121 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews121  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 7 Simon Fraser (smfr) 2018-11-07 13:47:29 PST
https://trac.webkit.org/r237942
Comment 8 Alexey Proskuryakov 2019-05-11 16:18:57 PDT
*** Bug 189841 has been marked as a duplicate of this bug. ***
Comment 9 Alexey Proskuryakov 2019-05-11 16:34:12 PDT
*** Bug 189752 has been marked as a duplicate of this bug. ***