Bug 189841 - [Mojave WK1] Layout test compositing/repaint/iframes/compositing-iframe-with-fixed-background-doc-repaint.html is a flaky failure
Summary: [Mojave WK1] Layout test compositing/repaint/iframes/compositing-iframe-with-...
Status: RESOLVED DUPLICATE of bug 190627
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-09-21 10:22 PDT by Ryan Haddad
Modified: 2019-05-11 16:18 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-09-21 10:22:38 PDT
Layout test compositing/repaint/iframes/compositing-iframe-with-fixed-background-doc-repaint.html is a flaky failure on Mojave WK1 with the following diff:

--- /build//layout-test-results/compositing/repaint/iframes/compositing-iframe-with-fixed-background-doc-repaint-expected.txt
+++ /build//layout-test-results/compositing/repaint/iframes/compositing-iframe-with-fixed-background-doc-repaint-actual.txt
@@ -12,9 +12,6 @@
           (position 14.00 14.00)
           (bounds 432.00 332.00)
           (drawsContent 1)
-          (repaint rects
-            (rect 16.00 16.00 400.00 300.00)
-          )
           (children 1
             (GraphicsLayer
               (position 16.00 16.00)
@@ -33,9 +30,6 @@
                             (GraphicsLayer
                               (bounds 400.00 1016.00)
                               (drawsContent 1)
-                              (repaint rects
-                                (rect 8.00 8.00 100.00 100.00)
-                              )
                               (children 1
                                 (GraphicsLayer
                                   (position 8.00 108.00)
Comment 1 Radar WebKit Bug Importer 2018-09-21 10:23:41 PDT
<rdar://problem/44683900>
Comment 2 Dawei Fenton (:realdawei) 2018-10-22 15:06:12 PDT
marked as flaky in: https://trac.webkit.org/changeset/237333/webkit
Comment 3 Alexey Proskuryakov 2019-05-11 16:18:57 PDT
This was fixed 6 months ago.

*** This bug has been marked as a duplicate of bug 190627 ***