Bug 190210 - REGRESSION (r236501?): Layout Test compositing/geometry/limit-layer-bounds-opacity-transition.html is flaky
Summary: REGRESSION (r236501?): Layout Test compositing/geometry/limit-layer-bounds-op...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
: 190507 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-02 10:35 PDT by Truitt Savell
Modified: 2019-04-04 09:38 PDT (History)
10 users (show)

See Also:


Attachments
Patch for landing (1.73 KB, patch)
2019-04-04 09:00 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2018-10-02 10:35:48 PDT
The following layout test is flaky on all platforms

compositing/geometry/limit-layer-bounds-opacity-transition.html

Probable cause:

This test became flakey recently. I was able to reproduce the failure using run-webkit-tests --root testbuild-236502 compositing/geometry/limit-layer-bounds-opacity-transition.html --iterations 500 -f 

I ran this on Mojave. This gave me a range of possible revisions for the regression between 236497-236502. Looking at the revisions I think either 236500 or 236501 are at fault but I am not sure. 

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=compositing%2Fgeometry%2Flimit-layer-bounds-opacity-transition.html

Diff:
--- /Volumes/Data/slave/sierra-debug-tests-wk1/build/layout-test-results/compositing/geometry/limit-layer-bounds-opacity-transition-expected.txt
+++ /Volumes/Data/slave/sierra-debug-tests-wk1/build/layout-test-results/compositing/geometry/limit-layer-bounds-opacity-transition-actual.txt
@@ -7,7 +7,7 @@
     (GraphicsLayer
       (bounds 800.00 600.00)
       (contentsOpaque 1)
-      (children 2
+      (children 3
         (GraphicsLayer
           (position 8.00 8.00)
           (anchor 1.00 1.00)
@@ -18,6 +18,12 @@
           (bounds 108.00 99.00)
           (drawsContent 1)
         )
+        (GraphicsLayer
+          (position 8.00 109.00)
+          (bounds 784.00 18.00)
+          (opacity 0.00)
+          (drawsContent 1)
+        )
       )
     )
   )
Comment 1 Radar WebKit Bug Importer 2018-10-05 10:18:09 PDT
<rdar://problem/45045989>
Comment 2 Ryan Haddad 2018-10-12 13:56:52 PDT
*** Bug 190507 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Haddad 2018-10-23 09:59:03 PDT
Marked test as flaky in https://trac.webkit.org/r237352
Comment 4 Antoine Quint 2019-04-04 09:00:31 PDT
Created attachment 366720 [details]
Patch for landing
Comment 5 WebKit Commit Bot 2019-04-04 09:38:56 PDT
Comment on attachment 366720 [details]
Patch for landing

Clearing flags on attachment: 366720

Committed r243871: <https://trac.webkit.org/changeset/243871>
Comment 6 WebKit Commit Bot 2019-04-04 09:38:57 PDT
All reviewed patches have been landed.  Closing bug.