Bug 189848 - Implement picture-in-picture JS API
Summary: Implement picture-in-picture JS API
Status: RESOLVED DUPLICATE of bug 182688
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-09-21 12:24 PDT by Jeremy Jones
Modified: 2019-07-11 10:28 PDT (History)
7 users (show)

See Also:


Attachments
WIP (82.86 KB, patch)
2018-09-21 12:28 PDT, Jeremy Jones
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews107 for mac-sierra-wk2 (3.53 MB, application/zip)
2018-09-21 14:11 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Jones 2018-09-21 12:24:47 PDT
Implement picture-in-picture JS API
Comment 1 Jeremy Jones 2018-09-21 12:25:46 PDT
rdar://problem/43946395
Comment 2 Jeremy Jones 2018-09-21 12:28:41 PDT
Created attachment 350402 [details]
WIP
Comment 3 Build Bot 2018-09-21 14:11:43 PDT
Comment on attachment 350402 [details]
WIP

Attachment 350402 [details] did not pass mac-wk2-ews (mac-wk2):
Output: https://webkit-queues.webkit.org/results/9300872

New failing tests:
imported/w3c/web-platform-tests/picture-in-picture/shadow-dom.html
imported/w3c/web-platform-tests/picture-in-picture/disable-picture-in-picture.html
imported/w3c/web-platform-tests/picture-in-picture/request-picture-in-picture-twice.html
imported/w3c/web-platform-tests/picture-in-picture/request-picture-in-picture.html
js/dom/dom-static-property-for-in-iteration.html
imported/w3c/web-platform-tests/picture-in-picture/picture-in-picture-window.html
imported/w3c/web-platform-tests/picture-in-picture/leave-picture-in-picture.html
imported/w3c/web-platform-tests/picture-in-picture/picture-in-picture-element.html
imported/w3c/web-platform-tests/picture-in-picture/exit-picture-in-picture.html
imported/w3c/web-platform-tests/picture-in-picture/enter-picture-in-picture.html
Comment 4 Build Bot 2018-09-21 14:11:44 PDT
Created attachment 350423 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 5 Jon Lee 2018-09-24 10:13:11 PDT
We should add this to the feature status page.
Comment 6 Eric Carlson 2018-09-24 10:15:49 PDT
Comment on attachment 350402 [details]
WIP

View in context: https://bugs.webkit.org/attachment.cgi?id=350402&action=review

I don't see any ChangeLogs.

> Source/WebKit/Configurations/FeatureDefines.xcconfig:162
> +//ENABLE_PICTUREINPICTURE_API = $(ENABLE_PICTUREINPICTURE_API_$(WK_PLATFORM_NAME));
> +//ENABLE_PICTUREINPICTURE_API_iphoneos = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_iphonesimulator = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_IOS_SINCE_12 = ENABLE_PICTUREINPICTURE_API;
> +//ENABLE_PICTUREINPICTURE_API_macosx = ENABLE_PICTUREINPICTURE_API;

This doesn't look right.

> Source/WebKitLegacy/mac/Configurations/FeatureDefines.xcconfig:162
> +//ENABLE_PICTUREINPICTURE_API = $(ENABLE_PICTUREINPICTURE_API_$(WK_PLATFORM_NAME));
> +//ENABLE_PICTUREINPICTURE_API_iphoneos = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_iphonesimulator = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_IOS_SINCE_12 = ENABLE_PICTUREINPICTURE_API;
> +//ENABLE_PICTUREINPICTURE_API_macosx = ENABLE_PICTUREINPICTURE_API;

Ditto.

> Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig:162
> +//ENABLE_PICTUREINPICTURE_API = $(ENABLE_PICTUREINPICTURE_API_$(WK_PLATFORM_NAME));
> +//ENABLE_PICTUREINPICTURE_API_iphoneos = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_iphonesimulator = $(ENABLE_PICTUREINPICTURE_API$(WK_IOS_12));
> +//ENABLE_PICTUREINPICTURE_API_IOS_SINCE_12 = ENABLE_PICTUREINPICTURE_API;
> +//ENABLE_PICTUREINPICTURE_API_macosx = ENABLE_PICTUREINPICTURE_API;

Ditto.
Comment 7 Carlos Eduardo Ramalho 2019-07-10 12:28:53 PDT
Hi Jeremy, do you plan to continue working on this?

If not, I would like to play around with this in the next few weeks and see if I can send a patch.
Comment 8 Eric Carlson 2019-07-10 14:39:00 PDT
(In reply to Carlos Eduardo Ramalho from comment #7)
> Hi Jeremy, do you plan to continue working on this?
> 
> If not, I would like to play around with this in the next few weeks and see
> if I can send a patch.
>
Jeremy is no longer actively contributing to WebKit. Please feel free to take this over, I'll be happy to review patches!
Comment 9 Carlos Eduardo Ramalho 2019-07-11 08:53:24 PDT
(In reply to Eric Carlson from comment #8)
> (In reply to Carlos Eduardo Ramalho from comment #7)
> > Hi Jeremy, do you plan to continue working on this?
> > 
> > If not, I would like to play around with this in the next few weeks and see
> > if I can send a patch.
> >
> Jeremy is no longer actively contributing to WebKit. Please feel free to
> take this over, I'll be happy to review patches!

Great!

I see that bug 182688 also exists and is referred at https://github.com/WICG/picture-in-picture/blob/master/implementation-status.md

Maybe this bug would be a duplicate of that one?
Comment 10 Eric Carlson 2019-07-11 10:28:09 PDT
(In reply to Carlos Eduardo Ramalho from comment #9)
> (In reply to Eric Carlson from comment #8)
> > (In reply to Carlos Eduardo Ramalho from comment #7)
> > > Hi Jeremy, do you plan to continue working on this?
> > > 
> > > If not, I would like to play around with this in the next few weeks and see
> > > if I can send a patch.
> > >
> > Jeremy is no longer actively contributing to WebKit. Please feel free to
> > take this over, I'll be happy to review patches!
> 
> Great!
> 
> I see that bug 182688 also exists and is referred at
> https://github.com/WICG/picture-in-picture/blob/master/implementation-status.
> md
> 
> Maybe this bug would be a duplicate of that one?

Indeed, I have duped this to bug 182688.

*** This bug has been marked as a duplicate of bug 182688 ***