Bug 189750 - Web Inspector: logged messages ending with "<file>:<line>:<column>" are not displayed
Summary: Web Inspector: logged messages ending with "<file>:<line>:<column>" are not d...
Status: RESOLVED DUPLICATE of bug 188946
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: Safari 11
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-09-19 09:31 PDT by Nick Fitzgerald
Modified: 2018-10-19 08:07 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot: Safari devtools show a blank message (first logged message; ignore the following unreachable exception) (60.86 KB, image/png)
2018-09-19 09:31 PDT, Nick Fitzgerald
no flags Details
Screenshot: Firefox devtools correctly show the logged message. This is what I would expect from the safari devtools as well. (26.64 KB, image/png)
2018-09-19 09:32 PDT, Nick Fitzgerald
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Fitzgerald 2018-09-19 09:31:27 PDT
Created attachment 350123 [details]
Screenshot: Safari devtools show a blank message (first logged message; ignore the following unreachable exception)

# Steps to reproduce:

* Open the console
* Enter: `console.log("abc:1:2")`

# Expected Results:

There is a "abc:1:2" message that gets logged and displayed.

# Actual Results:

There is a message that gets logged, but it does not contain "abc:1:2". Instead, it is blank.

--------------------------------------------------

This also affects `console.error`, and I assume other console logging methods.

If I add a space to the end of the log message, then it displays properly, i.e. `console.log("abc:1:2 ")`.

Originally filed as https://github.com/rustwasm/console_error_panic_hook/issues/7
Comment 1 Nick Fitzgerald 2018-09-19 09:32:21 PDT
Created attachment 350124 [details]
Screenshot: Firefox devtools correctly show the logged message. This is what I would expect from the safari devtools as well.
Comment 2 Brian Burg 2018-09-19 09:34:16 PDT
Thanks for the report Nick. What version of Safari did you test?
Comment 3 Radar WebKit Bug Importer 2018-09-19 09:34:32 PDT
<rdar://problem/44605402>
Comment 4 Nick Fitzgerald 2018-09-19 09:52:58 PDT
I'm actually acting as a proxy on this one, since I happen to be on Linux at the moment, but I am told Safari 12 repros the bug. I don't know what version the original reporter was on, I'll ask in the original github issue we got.
Comment 5 Nick Fitzgerald 2018-09-19 10:51:30 PDT
The original bug reporter is on Safari Version 11.1.2 (13605.3.8)
Comment 6 Joseph Pecoraro 2018-09-19 12:27:57 PDT
This would have been fixed super recently by Devin's change. It looks the case where `isLikelyStackTrace` was considering this a stack trace too eagerly.
Comment 7 Joseph Pecoraro 2018-09-19 12:33:22 PDT

*** This bug has been marked as a duplicate of bug 188946 ***