Bug 188421 - REGRESSION (r234330): [mac-wk1] Layout Test fast/repaint/animation-after-layer-scroll.html is a flaky failure
Summary: REGRESSION (r234330): [mac-wk1] Layout Test fast/repaint/animation-after-laye...
Status: RESOLVED DUPLICATE of bug 188357
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-08-08 14:56 PDT by Dawei Fenton (:realdawei)
Modified: 2019-05-11 15:59 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dawei Fenton (:realdawei) 2018-08-08 14:56:53 PDT
The following layout test is failing on mac WK1 (Debug and Release)

fast/repaint/animation-after-layer-scroll.html

Probable cause:

Unknown, here's a sample diff: 
--- /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/fast/repaint/animation-after-layer-scroll-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/fast/repaint/animation-after-layer-scroll-actual.txt
@@ -3,7 +3,7 @@
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS layerTreeAsText.indexOf('repaint rect') > -1 is true
+FAIL layerTreeAsText.indexOf('repaint rect') > -1 should be true. Was false.
 PASS successfullyParsed is true
 
 TEST COMPLETE

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Frepaint%2Fanimation-after-layer-scroll.html
Comment 1 Truitt Savell 2018-09-06 16:15:51 PDT
I found that this test and another listed below fail together on the same test runner:
fast/repaint/animation-after-layer-scroll.html
fast/repaint/canvas-object-fit.html from https://bugs.webkit.org/show_bug.cgi?id=188910

I was able to reproduce the failures by pulling the test runner list from a failing run that contained these two tests and running it using command:

run-webkit-tests --root testbuild-235740 --test-list TEST_LIST_LOCATION --child-processes 1 -1

I am going to bisect the list down to something more manageable 

Note: fast/repaint/canvas-object-fit.html will set its own state so if it is ran in iterations it will fail every time.
Comment 2 Truitt Savell 2018-09-06 16:45:23 PDT
This command can reproduce both failures:

run-webkit-tests --root testbuild-235740 fast/multicol/newmulticol/multicol-inside-multicol.html fast/repaint/animation-after-layer-scroll.html fast/repaint/canvas-object-fit.html --child-processes 1 -1

fast/multicol/newmulticol/multicol-inside-multicol.html is casting a state to be set that causes both of these tests to fail if they are in the same run.
Comment 3 Truitt Savell 2018-09-06 17:05:01 PDT
After bisecting through revisions I believe this test became flakey with https://trac.webkit.org/changeset/234330/webkit.

running the command above on r234329 causes no failures and on 234330 it does fail.
Comment 4 Radar WebKit Bug Importer 2018-09-25 10:10:45 PDT
<rdar://problem/44764569>
Comment 5 Dawei Fenton (:realdawei) 2018-10-22 16:57:26 PDT
marked flaky in: https://trac.webkit.org/changeset/237339/webkit
Comment 6 Alexey Proskuryakov 2019-05-11 15:59:16 PDT
This was fixed in r244675. The test was not in TestExpectations.

*** This bug has been marked as a duplicate of bug 188357 ***