Bug 188910 - [mac-wk1] Layout Test fast/repaint/canvas-object-fit.html is a flaky failure
Summary: [mac-wk1] Layout Test fast/repaint/canvas-object-fit.html is a flaky failure
Status: RESOLVED DUPLICATE of bug 188357
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-23 17:13 PDT by Ryan Haddad
Modified: 2019-05-11 16:03 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-08-23 17:13:19 PDT
The following layout test is failing on macOS WK1

fast/repaint/canvas-object-fit.html

Probable cause:

Unknown.

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Frepaint%2Fcanvas-object-fit.html

--- /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/fast/repaint/canvas-object-fit-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/fast/repaint/canvas-object-fit-actual.txt
@@ -1,21 +1 @@
- (GraphicsLayer
-  (anchor 0.00 0.00)
-  (bounds 800.00 600.00)
-  (children 1
-    (GraphicsLayer
-      (bounds 800.00 600.00)
-      (contentsOpaque 1)
-      (children 1
-        (GraphicsLayer
-          (position 8.00 8.00)
-          (bounds 202.00 102.00)
-          (drawsContent 1)
-          (repaint rects
-            (rect 70.00 20.00 7.00 7.00)
-          )
-        )
-      )
-    )
-  )
-)
Comment 1 Truitt Savell 2018-09-06 16:16:00 PDT
Tracking a repro case for this test and another in https://bugs.webkit.org/show_bug.cgi?id=188421
Comment 3 Truitt Savell 2018-09-06 16:45:56 PDT
This command can reproduce both failures from https://bugs.webkit.org/show_bug.cgi?id=188421:

run-webkit-tests --root testbuild-235740 fast/multicol/newmulticol/multicol-inside-multicol.html fast/repaint/animation-after-layer-scroll.html fast/repaint/canvas-object-fit.html --child-processes 1 -1

fast/multicol/newmulticol/multicol-inside-multicol.html is casting a state to be set that causes both of these tests to fail if they are in the same run.
Comment 4 Alexey Proskuryakov 2019-05-11 16:03:15 PDT
This was fixed in r244675. Removed test expectations in http://trac.webkit.org/r245210.

*** This bug has been marked as a duplicate of bug 188357 ***