Bug 186994 - Dragging shadow DOM child immediately triggers dragend
Summary: Dragging shadow DOM child immediately triggers dragend
Status: RESOLVED DUPLICATE of bug 136836
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Safari 11
Hardware: Macintosh macOS 10.13
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 148695
  Show dependency treegraph
 
Reported: 2018-06-25 01:38 PDT by Achim
Modified: 2018-09-20 23:27 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim 2018-06-25 01:38:38 PDT
Hi there,

When setting a Web Component to be draggable and starting the drag operation (via mouse down) on a child of that Web Component within its shadow DOM, the dragstart event is immediately followed by dragend and the drag operation is cancelled. Dragging the shadow DOM host itself works fine.

Simple Example:
https://codepen.io/a-xin/pen/XYBpNG?editors=1001

Environment:
macOS 10.13, Safari 11.1

Other browsers:
Starting the drag operation on either the host or the child works fine in Firefox and Chrome.

Impact:
Drag-and-drop does not work when using Web Components
Comment 1 Ryosuke Niwa 2018-09-20 23:27:51 PDT
Thanks for the bug report! We've identified this bug as a duplicate of the bug 136836.

*** This bug has been marked as a duplicate of bug 136836 ***