Bug 136836 - Cannot start a drag inside a shadow tree when an inclusive-ancestor of its shadow host is a draggable element
Summary: Cannot start a drag inside a shadow tree when an inclusive-ancestor of its sh...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords: InRadar
: 186994 187940 (view as bug list)
Depends on:
Blocks: 148695
  Show dependency treegraph
 
Reported: 2014-09-15 14:23 PDT by Jer Noble
Modified: 2019-02-06 09:19 PST (History)
8 users (show)

See Also:


Attachments
Fixes the bug (10.34 KB, patch)
2018-09-21 00:57 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews123 for ios-simulator-wk2 (8.31 MB, application/zip)
2018-09-21 02:49 PDT, Build Bot
no flags Details
Skip the tests on iOS for real (11.15 KB, patch)
2018-09-21 16:28 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Fixed GTK+ build (11.55 KB, patch)
2018-09-21 21:52 PDT, Ryosuke Niwa
wenson_hsieh: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2014-09-15 14:23:03 PDT
Investigate whether drags from within the shadow DOM should initiate drag events targetting the hosting element.
Comment 1 Ryosuke Niwa 2017-10-09 22:06:57 PDT
(In reply to Jer Noble from comment #0)
> Investigate whether drags from within the shadow DOM should initiate drag
> events targetting the hosting element.

It should!
Comment 2 Radar WebKit Bug Importer 2018-08-01 22:29:30 PDT
<rdar://problem/42842787>
Comment 3 Ryosuke Niwa 2018-09-20 22:43:48 PDT
*** Bug 187940 has been marked as a duplicate of this bug. ***
Comment 4 Ryosuke Niwa 2018-09-20 23:27:51 PDT
*** Bug 186994 has been marked as a duplicate of this bug. ***
Comment 5 Ryosuke Niwa 2018-09-21 00:57:52 PDT
Created attachment 350336 [details]
Fixes the bug
Comment 6 Build Bot 2018-09-21 02:49:53 PDT
Comment on attachment 350336 [details]
Fixes the bug

Attachment 350336 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/9293579

New failing tests:
fast/shadow-dom/dragging-element-with-shadow-tree.html
fast/shadow-dom/dragging-element-inside-shadow-tree.html
Comment 7 Build Bot 2018-09-21 02:49:55 PDT
Created attachment 350343 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 8 Ryosuke Niwa 2018-09-21 16:06:02 PDT
WTF!? Why is iOS WK2 running these tests?
Comment 9 Ryan Haddad 2018-09-21 16:27:19 PDT
(In reply to Ryosuke Niwa from comment #8)
> WTF!? Why is iOS WK2 running these tests?

This pre-existing TestExpectations entry is probably to blame:
LayoutTests/platform/ios/TestExpectations:781:webkit.org/b/148695 fast/shadow-dom [ Pass ]
Comment 10 Ryosuke Niwa 2018-09-21 16:28:46 PDT
Created attachment 350452 [details]
Skip the tests on iOS for real
Comment 11 Ryosuke Niwa 2018-09-21 21:52:04 PDT
Created attachment 350496 [details]
Fixed GTK+ build
Comment 12 Ryosuke Niwa 2018-09-22 01:11:25 PDT
Thanks for the review!
Comment 13 Ryosuke Niwa 2018-09-22 01:13:54 PDT
Committed r236384: <https://trac.webkit.org/changeset/236384>
Comment 14 Lucas Forschler 2019-02-06 09:19:05 PST
Mass move bugs into the DOM component.