Bug 184417 - CSS: filter should reject negative brightness
Summary: CSS: filter should reject negative brightness
Status: RESOLVED DUPLICATE of bug 184937
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari 11
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: FromImplementor, InRadar
Depends on:
Blocks:
 
Reported: 2018-04-09 07:37 PDT by Eric Willigers
Modified: 2018-04-25 17:59 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Willigers 2018-04-09 07:37:03 PDT
https://drafts.fxtf.org/filter-effects/#FilterProperty

brightness() = brightness( <number-percentage> )
Negative values are not allowed.

However, WebKit and Blink currently accept negative values.
https://jsfiddle.net/ericwilligers/y4j8hzvs/

Corresponding Blink bug:
https://bugs.chromium.org/p/chromium/issues/detail?id=776208
Comment 1 Radar WebKit Bug Importer 2018-04-12 12:26:05 PDT
<rdar://problem/39389946>
Comment 2 Simon Fraser (smfr) 2018-04-25 17:59:09 PDT
Fixed via bug 184937.

*** This bug has been marked as a duplicate of bug 184937 ***