Bug 184937 - brightness() filter should default to 1, and not allow negative values
Summary: brightness() filter should default to 1, and not allow negative values
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 184417 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-24 14:26 PDT by Simon Fraser (smfr)
Modified: 2018-04-25 17:59 PDT (History)
6 users (show)

See Also:


Attachments
Patch (40.03 KB, patch)
2018-04-25 14:14 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (40.04 KB, patch)
2018-04-25 14:23 PDT, Simon Fraser (smfr)
dino: review+
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-sierra (2.30 MB, application/zip)
2018-04-25 15:27 PDT, EWS Watchlist
no flags Details
Patch (45.06 KB, patch)
2018-04-25 15:28 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews122 for ios-simulator-wk2 (12.18 MB, application/zip)
2018-04-25 16:06 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews112 for mac-sierra (3.13 MB, application/zip)
2018-04-25 16:24 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2018-04-24 14:26:13 PDT
Default value for brightness() is wrong. It should be 1, according to https://drafts.fxtf.org/filter-effects/
Comment 1 Simon Fraser (smfr) 2018-04-24 14:44:42 PDT
We also allow brightness(-0.4) and should not.
Comment 2 Simon Fraser (smfr) 2018-04-25 14:14:39 PDT
Created attachment 338790 [details]
Patch
Comment 3 Simon Fraser (smfr) 2018-04-25 14:23:16 PDT
Created attachment 338792 [details]
Patch
Comment 4 EWS Watchlist 2018-04-25 15:27:55 PDT
Comment on attachment 338792 [details]
Patch

Attachment 338792 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7459399

New failing tests:
css3/color-filters/color-filter-parsing.html
fast/filter-image/parse-filter-image.html
Comment 5 EWS Watchlist 2018-04-25 15:27:56 PDT
Created attachment 338809 [details]
Archive of layout-test-results from ews101 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 6 Simon Fraser (smfr) 2018-04-25 15:28:59 PDT
Created attachment 338810 [details]
Patch
Comment 7 EWS Watchlist 2018-04-25 16:06:43 PDT
Comment on attachment 338792 [details]
Patch

Attachment 338792 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/7459651

New failing tests:
css3/color-filters/color-filter-parsing.html
fast/filter-image/parse-filter-image.html
css3/filters/effect-brightness.html
css3/filters/effect-brightness-clamping.html
Comment 8 EWS Watchlist 2018-04-25 16:06:44 PDT
Created attachment 338815 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.4
Comment 9 EWS Watchlist 2018-04-25 16:24:05 PDT
Comment on attachment 338792 [details]
Patch

Attachment 338792 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/7460222

New failing tests:
css3/color-filters/color-filter-parsing.html
fast/filter-image/parse-filter-image.html
Comment 10 EWS Watchlist 2018-04-25 16:24:07 PDT
Created attachment 338818 [details]
Archive of layout-test-results from ews112 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 11 Simon Fraser (smfr) 2018-04-25 16:25:08 PDT
https://trac.webkit.org/changeset/231033/webkit
Comment 12 Radar WebKit Bug Importer 2018-04-25 16:27:18 PDT
<rdar://problem/39739703>
Comment 13 Simon Fraser (smfr) 2018-04-25 17:59:09 PDT
*** Bug 184417 has been marked as a duplicate of this bug. ***