Bug 183392 - commit-queue failed with error: There are too many unreachable loose objects; run git prune to remove them
Summary: commit-queue failed with error: There are too many unreachable loose objects;...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aakash Jain
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-06 17:54 PST by Aakash Jain
Modified: 2018-05-25 16:24 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aakash Jain 2018-03-06 17:54:53 PST
commit-queue failed in https://bugs.webkit.org/show_bug.cgi?id=183299

It seems to have landed the patch, but it shows that it failed.  https://webkit-queues.webkit.org/results/6833744


It's logs have following error:


Last 500 characters of output:
ls/ChangeLog
r229349 = c3710bd8a5d1173ab6b53e0d79ece83f5b3421d1 (refs/remotes/origin/master)
Auto packing the repository in background for optimum performance.
See "git help gc" for manual housekeeping.
error: The last gc run reported the following. Please correct the root cause
and remove .git/gc.log.
Automatic cleanup will not be performed until the file is removed.

warning: There are too many unreachable loose objects; run 'git prune' to remove them.

gc --auto: command returned error: 255
Comment 1 Alexey Proskuryakov 2018-03-06 20:18:26 PST
I saw it in another bug today, too.
Comment 2 Aakash Jain 2018-03-06 22:27:28 PST
Another similar failure in https://bugs.webkit.org/show_bug.cgi?id=183396  (https://webkit-queues.webkit.org/results/6835274)
Comment 3 Aakash Jain 2018-03-06 22:41:40 PST
This error is happening only on webkit-cq-02 machine. Logs on webkit-cq-01 and webkit-cq-03 doesn't have this error. I just manually run "git prune" on webkit-cq-02. Let's see if that helps.
Comment 4 Alexey Proskuryakov 2018-03-07 09:03:25 PST
This night, it happened on webkit-cq-01 in bug 183400.
Comment 6 Aakash Jain 2018-03-07 15:39:44 PST
Observation: The issue didn't happened on webkit-cq-02 after I run "git prune" yesterday night. It started happening on webkit-cq-01.
Comment 7 Aakash Jain 2018-03-07 15:40:10 PST
Did following to fix/improve this:

1) Run "git prune" on all the webkit-cq-* machines. 

2) Configured following variables to have better git gc:

git config --global gc.reflogExpire 30    (defaults to 90 days)
git config --global gc.reflogExpireUnreachable 10  (defaults to 30 days)

Reference: https://git-scm.com/docs/git-gc#_configuration

3) Running "git gc --aggressive" currently.
Comment 8 Aakash Jain 2018-05-25 16:24:23 PDT
Closing it as we haven't seen this issue again after doing configuration changes.