Bug 183382 - Remove WebCookieManager and messaging from WebContent process.
Summary: Remove WebCookieManager and messaging from WebContent process.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on:
Blocks: 183486 183519
  Show dependency treegraph
 
Reported: 2018-03-06 13:19 PST by Brent Fulgham
Modified: 2018-03-09 12:16 PST (History)
9 users (show)

See Also:


Attachments
Patch (29.40 KB, patch)
2018-03-06 17:36 PST, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch (32.07 KB, patch)
2018-03-06 17:44 PST, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch (55.18 KB, patch)
2018-03-06 17:55 PST, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch (58.74 KB, patch)
2018-03-07 09:16 PST, Brent Fulgham
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews204 for win-future (12.00 MB, application/zip)
2018-03-07 10:58 PST, Build Bot
no flags Details
Patch (59.41 KB, patch)
2018-03-07 16:15 PST, Brent Fulgham
no flags Details | Formatted Diff | Diff
Patch for landing (59.43 KB, patch)
2018-03-08 08:16 PST, Brent Fulgham
commit-queue: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-cq-02 for mac-sierra (1.74 MB, application/zip)
2018-03-08 09:12 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2018-03-06 13:19:59 PST
We have removed networking access from the WebContent process (see Bug 183192 and related), and no longer need the UIProcess to ask the WebContent process about networking-related things.

This bug removes some left-over WebCookieStore API stuff that still asks the WebContent process about things it no longer knows anything about.
Comment 1 Radar WebKit Bug Importer 2018-03-06 13:20:35 PST
<rdar://problem/38191450>
Comment 2 Brent Fulgham 2018-03-06 17:36:52 PST
Created attachment 335163 [details]
Patch
Comment 3 Brent Fulgham 2018-03-06 17:44:13 PST
Created attachment 335164 [details]
Patch
Comment 4 Brent Fulgham 2018-03-06 17:55:36 PST
Created attachment 335166 [details]
Patch
Comment 5 Brent Fulgham 2018-03-07 09:16:39 PST
Created attachment 335196 [details]
Patch
Comment 6 Alex Christensen 2018-03-07 09:52:28 PST
Comment on attachment 335196 [details]
Patch

r=me
don't break gtk
Comment 7 Build Bot 2018-03-07 10:58:15 PST
Comment on attachment 335196 [details]
Patch

Attachment 335196 [details] did not pass win-ews (win):
Output: http://webkit-queues.webkit.org/results/6841105

New failing tests:
http/wpt/resource-timing/rt-initiatorType-media.html
Comment 8 Build Bot 2018-03-07 10:58:25 PST
Created attachment 335199 [details]
Archive of layout-test-results from ews204 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews204  Port: win-future  Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Comment 9 Brent Fulgham 2018-03-07 16:15:37 PST
Created attachment 335239 [details]
Patch
Comment 10 Brent Fulgham 2018-03-08 08:16:28 PST
Created attachment 335298 [details]
Patch for landing
Comment 11 WebKit Commit Bot 2018-03-08 09:12:55 PST
Comment on attachment 335298 [details]
Patch for landing

Rejecting attachment 335298 [details] from commit-queue.

Number of test failures exceeded the failure limit.
Full output: http://webkit-queues.webkit.org/results/6857355
Comment 12 WebKit Commit Bot 2018-03-08 09:12:56 PST
Created attachment 335302 [details]
Archive of layout-test-results from webkit-cq-02 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the commit-queue.
Bot: webkit-cq-02  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 13 Brent Fulgham 2018-03-08 12:41:16 PST
(In reply to WebKit Commit Bot from comment #12)
> Created attachment 335302 [details]
> Archive of layout-test-results from webkit-cq-02 for mac-sierra
> 
> The attached test failures were seen while running run-webkit-tests on the
> commit-queue.
> Bot: webkit-cq-02  Port: mac-sierra  Platform: Mac OS X 10.12.6

These failures do not reproduce locally, and don't seem to be related to dormant cookie code in the WebContent process.
Comment 14 Brent Fulgham 2018-03-08 12:43:36 PST
Committed r229426: <https://trac.webkit.org/changeset/229426>
Comment 15 Carlos Alberto Lopez Perez 2018-03-08 15:48:24 PST
(In reply to Brent Fulgham from comment #14)
> Committed r229426: <https://trac.webkit.org/changeset/229426>

It seems this has broken both GTK and WPE builds: https://build.webkit.org/builders/WPE%20Linux%2064-bit%20Release%20%28Build%29/builds/9314
Comment 16 Brent Fulgham 2018-03-08 16:32:30 PST
(In reply to Carlos Alberto Lopez Perez from comment #15)
> (In reply to Brent Fulgham from comment #14)
> > Committed r229426: <https://trac.webkit.org/changeset/229426>
> 
> It seems this has broken both GTK and WPE builds:
> https://build.webkit.org/builders/WPE%20Linux%2064-
> bit%20Release%20%28Build%29/builds/9314

Yes, I've been trying for two days on IRC to get a GTK person to take a look. Can anyone help fix the GTK build?
Comment 17 Brent Fulgham 2018-03-08 16:41:27 PST
WPE (and GTK) Failure looks like this:

[668/857] Linking CXX executable bin/WPENetworkProcess
FAILED: bin/WPENetworkProcess 
: && /usr/lib/ccache/c++   -fdiagnostics-color=always -Wno-attributes -Wno-maybe-uninitialized -Wwrite-strings -Wundef -Wpointer-arith -Wmissing-format-attribute -Wformat-security -Wcast-align -Wextra -Wall  -fno-strict-aliasing -fno-exceptions -std=c++14 -fno-rtti -O3 -DNDEBUG  -L/home/buildbot/wpe/wpe-linux-64-release/build/WebKitBuild/DependenciesWPE/Root/lib -fuse-ld=gold -Wl,--disable-new-dtags Source/WebKit/CMakeFiles/NetworkProcess.dir/NetworkProcess/EntryPoint/unix/NetworkProcessMain.cpp.o  -o bin/WPENetworkProcess  -Wl,-rpath,/home/buildbot/wpe/wpe-linux-64-release/build/WebKitBuild/Release/lib: -rdynamic lib/libWPEWebKit.so.1.0.0 lib/libWebCore.a lib/libPAL.a lib/libJavaScriptCore.a lib/libWTF.a lib/libbmalloc.a -ldl  ../DependenciesWPE/Root/lib/libWPEBackend.so && :
lib/libWPEWebKit.so.1.0.0: error: undefined reference to 'non-virtual thunk to WebKit::WebCookieManager::didReceiveMessage(IPC::Connection&, IPC::Decoder&)'
lib/libWPEWebKit.so.1.0.0: error: undefined reference to 'WebKit::WebCookieManager::didReceiveMessage(IPC::Connection&, IPC::Decoder&)'

The WebCookieManager message handling doesn't seem to be getting generated, even though it appears in the CMakeLists.txt and SourcesWPE.txt/SourcesGTK.txt files.
Comment 18 Michael Catanzaro 2018-03-08 17:00:06 PST
Committed r229442: <https://trac.webkit.org/changeset/229442>
Comment 19 Michael Catanzaro 2018-03-08 17:11:12 PST
(In reply to Brent Fulgham from comment #16)
> Yes, I've been trying for two days on IRC to get a GTK person to take a
> look. Can anyone help fix the GTK build?

Problem is that most of our team is only available on IRC during European business hours. I'm the exception, but I'm IP banned from freenode since I use a proxy service.

Probably the easiest way to get our attention is to just leave a comment here on Bugzilla and CC us, either individually, or better our bugs-noreply@webkitgtk.org email.