Bug 182481 - Flaky Test: imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html
Summary: Flaky Test: imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-pref...
Status: RESOLVED DUPLICATE of bug 182270
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2018-02-05 05:38 PST by WebKit Commit Bot
Modified: 2018-02-07 14:13 PST (History)
6 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-01 (2.28 MB, application/zip)
2018-02-05 05:39 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-02-05 05:38:59 PST
This is an automatically generated bug from the commit-queue.
imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html has been flaky on the commit-queue.

imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html was authored by youennf@gmail.com.
https://trac.webkit.org/browser/trunk/LayoutTests/imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html

The commit-queue just saw imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html flake (DumpRenderTree crashed) while processing attachment 333075 [details] on bug 180290.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-02-05 05:39:00 PST
Created attachment 333077 [details]
Archive of layout-test-results from webkit-cq-01
Comment 2 Alexey Proskuryakov 2018-02-06 12:45:20 PST
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html

Commit queue hit a release crash; this test also failed with an assertion in debug once recently:

Thread 34 Crashed:: WebCore: Worker
0   com.apple.JavaScriptCore      	0x00000001037f3394 WTFCrash + 36 (Assertions.cpp:272)
1   com.apple.JavaScriptCore      	0x00000001037f86db WTF::AtomicStringImpl::remove(WTF::AtomicStringImpl*) + 267 (AtomicStringImpl.cpp:489)
2   com.apple.JavaScriptCore      	0x000000010385fa74 WTF::StringImpl::~StringImpl() + 212 (StringImpl.cpp:120)
3   com.apple.JavaScriptCore      	0x000000010385fc55 WTF::StringImpl::~StringImpl() + 21 (StringImpl.cpp:141)
4   com.apple.JavaScriptCore      	0x000000010385fc75 WTF::StringImpl::destroy(WTF::StringImpl*) + 21 (StringImpl.cpp:146)
5   com.apple.WebCore             	0x000000010ebd96bf WTF::StringImpl::deref() + 47 (StringImpl.h:1058)
6   com.apple.WebCore             	0x000000010ebd962e void WTF::derefIfNotNull<WTF::StringImpl>(WTF::StringImpl*) + 46 (RefPtr.h:46)
7   com.apple.WebCore             	0x000000010ebd95f9 WTF::RefPtr<WTF::StringImpl, WTF::DumbPtrTraits<WTF::StringImpl> >::~RefPtr() + 41 (RefPtr.h:70)
8   com.apple.WebCore             	0x000000010ebd95c5 WTF::RefPtr<WTF::StringImpl, WTF::DumbPtrTraits<WTF::StringImpl> >::~RefPtr() + 21 (RefPtr.h:70)
9   com.apple.WebCore             	0x000000010ebd95a5 WTF::String::~String() + 21 (WTFString.h:136)
10  com.apple.WebCore             	0x000000010ebd8df5 WTF::String::~String() + 21 (WTFString.h:136)
11  com.apple.WebCore             	0x000000010ebebdd5 WTF::AtomicString::~AtomicString() + 21 (AtomicString.h:42)
12  com.apple.WebCore             	0x000000010ebeaa45 WTF::AtomicString::~AtomicString() + 21 (AtomicString.h:42)
13  com.apple.WebCore             	0x000000011140dd63 WebCore::CachedResourceRequestInitiators::~CachedResourceRequestInitiators() + 67 (CachedResourceRequestInitiators.h:33)
14  com.apple.WebCore             	0x000000011140dcf5 WebCore::CachedResourceRequestInitiators::~CachedResourceRequestInitiators() + 21 (CachedResourceRequestInitiators.h:33)
15  com.apple.WebCore             	0x00000001113f95ed WebCore::ThreadGlobalData::~ThreadGlobalData() + 1261 (ThreadGlobalData.cpp:59)
Comment 3 youenn fablet 2018-02-06 13:57:39 PST
The assertion that is hit seems to be:
ASSERT_WITH_MESSAGE(iterator != atomicStringTable.end(), "The string being removed is atomic in the string table of an other thread!");

I doubt that this is imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-preflight.any.html since it has no workers.
Probably one of the previous test being run.
Comment 4 youenn fablet 2018-02-06 13:59:14 PST
Looking at https://build.webkit.org/builders/Apple%20High%20Sierra%20Debug%20WK1%20(Tests)/builds/2136/steps/layout-test/logs/stdio, the culprit might be imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-credentials.any.worker.html

14:09:32.189 35822 worker/0 imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-credentials.any.worker.html output stderr lines:
14:09:32.189 35822   ASSERTION FAILED: The string being removed is atomic in the string table of an other thread!
14:09:32.189 35822   iterator != atomicStringTable.end()
14:09:32.189 35822   /Volumes/Data/slave/highsierra-debug/build/Source/WTF/wtf/text/AtomicStringImpl.cpp(489) : static void WTF::AtomicStringImpl::remove(WTF::AtomicStringImpl *)
14:09:32.189 35822   1   0x1037f338d WTFCrash
14:09:32.189 35822   2   0x1037f86db WTF::AtomicStringImpl::remove(WTF::AtomicStringImpl*)
14:09:32.189 35822   3   0x10385fa74 WTF::StringImpl::~StringImpl()
14:09:32.189 35822   4   0x10385fc55 WTF::StringImpl::~StringImpl()
14:09:32.189 35822   5   0x10385fc75 WTF::StringImpl::destroy(WTF::StringImpl*)
14:09:32.189 35822   6   0x10ebd96bf WTF::StringImpl::deref()
14:09:32.189 35822   7   0x10ebd962e void WTF::derefIfNotNull<WTF::StringImpl>(WTF::StringImpl*)
14:09:32.189 35822   8   0x10ebd95f9 WTF::RefPtr<WTF::StringImpl, WTF::DumbPtrTraits<WTF::StringImpl> >::~RefPtr()
14:09:32.189 35822   9   0x10ebd95c5 WTF::RefPtr<WTF::StringImpl, WTF::DumbPtrTraits<WTF::StringImpl> >::~RefPtr()
14:09:32.189 35822   10  0x10ebd95a5 WTF::String::~String()
14:09:32.190 35822   11  0x10ebd8df5 WTF::String::~String()
14:09:32.190 35822 worker/0 imported/w3c/web-platform-tests/fetch/api/cors/cors-redirect-credentials.any.worker.html passed
Comment 5 Alexey Proskuryakov 2018-02-07 14:10:25 PST
There was also some wrongfulness with resource loader threading in bug 182422, so it could also be that.
Comment 6 Alexey Proskuryakov 2018-02-07 14:13:40 PST
Duping all of these to the oldest bug.

*** This bug has been marked as a duplicate of bug 182270 ***