Bug 18140 - Using shift in gmail acts as tab
Summary: Using shift in gmail acts as tab
Status: RESOLVED DUPLICATE of bug 16381
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P5 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug
Depends on:
Blocks:
 
Reported: 2008-03-27 03:57 PDT by Francois Hensley
Modified: 2008-07-30 04:45 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Hensley 2008-03-27 03:57:44 PDT
MacOS X.5 on a MacBook Pro Core Duo, 2.16Ghz, 2GB Ram.

When going to gmail.com, and composing a mail, when in the textarea, when the left/right shift key is pressed, it acts as a tab and moves the cursor to the address field.

After a bit or debuggin, I found the offending code in :
./WebCore/platform/mac/KeyEventMac.mm on line 780

When commenting out the offending line as such :

        case 56: // Left Shift
        case 60: // Right Shift
            //return ([event modifierFlags] & NSShiftKeyMask) == 0;

the problem is rectified. However, this is untested on other platforms/OS'.

Thanks
Comment 1 Matt Lilek 2008-03-27 09:20:32 PDT
I can't get this to happen on GMail at all (v1 or v2).
Comment 2 Adam Roben (:aroben) 2008-03-27 09:32:43 PDT
Sounds like bug 16381 to me.
Comment 3 Francois Hensley 2008-03-27 09:36:18 PDT
Hi.

Yes it looks like the same bug, however, I can reproduce it every time using the nightly build. And this is on gmail v2.
Comment 4 Alexey Proskuryakov 2008-03-27 13:48:40 PDT
Are you using a localized version of GMail (I'm not sure if it is already localized to any languages though)? If you do, could you please check if this also happens for you with English localization?
Comment 5 Francois Hensley 2008-03-28 02:26:24 PDT
Nope, using the normal english version.
Comment 6 Eric Seidel (no email) 2008-04-14 00:08:02 PDT
I'm not able to reproduce this in Gmail.  However I thought that all international gmail accounts were still getting v1 regardless?
Comment 7 Alexey Proskuryakov 2008-04-14 00:14:56 PDT
For me, the ability to choose v1 or v2 only depends on the language I choose in preferences. With Russian, I only get v1, but with English, I can choose v2, which doesn't have this problem.
Comment 8 Oliver Hunt 2008-04-14 00:20:28 PDT
This is probably a duplicate of https://bugs.webkit.org/show_bug.cgi?id=16381
Comment 9 Anthony Ricaud 2008-04-14 00:38:18 PDT
Can't reproduce this. Either on Gmail V1 or V2 and with Safari3.1 or nightly r31848.
Comment 10 Robert Blaut 2008-07-30 04:45:55 PDT
(In reply to comment #8)
> This is probably a duplicate of https://bugs.webkit.org/show_bug.cgi?id=16381
> 

Indeed.

(In reply to comment #9)
> Can't reproduce this. Either on Gmail V1 or V2 and with Safari3.1 or nightly
> r31848.
> 

I also cannot reproduce the problem in the latest nightly of WebKit

*** This bug has been marked as a duplicate of 16381 ***