Bug 16381 - REGRESSION: Shift, command, option, ctrl keys in Gmail Rich Text changes focus
Summary: REGRESSION: Shift, command, option, ctrl keys in Gmail Rich Text changes focus
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Major
Assignee: Nobody
URL: http://mail.google.com/mail?ui=1
Keywords: GoogleBug, InRadar, PlatformOnly, Regression
: 17315 17476 17527 17591 17704 17711 17914 17950 18140 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-10 07:29 PST by Ruben Bakker
Modified: 2008-07-30 04:45 PDT (History)
13 users (show)

See Also:
ddkilzer: CloneForRadar+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruben Bakker 2007-12-10 07:29:44 PST
This happens in Gmail 1.0 (not Gmail 2.0):

Pressing the shift key in a rich text (for example when composing a new message) changes the focus to another input field. This can lead to very confusing behavior:

Steps to duplicate the problem:
- Log into gmail (http://mail.google.com/mail?ui=1
- Make sure you are using Gmail 1.0, if not press the "Older version" link
- Click the "compose message" link
- Set focus to the message text
- press Shift --> Cursor moves to SUBJECT!

As this used to work, I have searched for the build where the problem started. #27337 (Nov 2.) works OK, #27373 create the same day has the bug. The problem could be duplicated with build #28565, too.

As many users still use Gmail 1.0 (Google Apps accounts/Gmail 2.0 still buggy) and as the bug makes Gmail 1.0 nearly unusable, I find this an important bug.
Comment 1 Alexey Proskuryakov 2007-12-11 00:12:48 PST
Confirmed with r28024.

Te change in question must be <http://trac.webkit.org/projects/webkit/changeset/27372> - I suspect that this is an evangelism issue.
Comment 2 David Kilzer (:ddkilzer) 2007-12-12 06:17:17 PST
<rdar://problem/5642990>
Comment 3 Justin Garcia 2007-12-12 14:13:36 PST
r27372 looks suspicious:

http://trac.webkit.org/projects/webkit/changeset/27372
Comment 4 Oliver Hunt 2007-12-12 14:18:45 PST
This bug only exists on old gmail, gmail 2 does not exhibit it.

There's a radar that was already closed i believe, but for the life of me i can't find it.
Comment 5 Oliver Hunt 2007-12-12 14:23:42 PST
People who are experiencing this, can you make sure google is serving you the new gmail (you'll see a link saying "Older Version" in the top right,  and you'll have google chat -- if you do have gmail 2 i'm worried.

If you aren't getting the new gmail do you see an option in the top right (near the sign out link) that says "Newer Version" -- if you do can you click it, and see whether you a) get the new version and b) this bug goes away.

Now if you don't have the ability to switch to the new gmail can you post what your useragent string is?
(http://whatsmyuseragent.com should do the trick)

Also, can you make sure you're using a recent nightly?

Thanks,
  Oliver
Comment 6 Oliver Hunt 2007-12-12 14:39:44 PST
Oh, i see many apologies, this is for people who are forcing gmail1 :-/

Yes this is an evangelism issue.
Comment 7 Oliver Hunt 2007-12-12 14:46:30 PST
Found it: <rdar://problem/5584167> REGRESSION: Command+a in GMail editor changes focus to the To: field
Comment 8 Alexey Proskuryakov 2007-12-12 22:57:48 PST
Hrm, it seems that localized versions of the new GMail are not available yet - I'm getting v1 without any kind of forcing, and do not see how to switch to v2.
Comment 9 Ruben Bakker 2007-12-13 22:58:02 PST
Google Apps ("own domain") accounts are still on Gmail 1.0, no Gmail 2.0 support here. Plus many users choose to stay on 1.0 for the moment:
- Contact auto completion bug (see http://mail.google.com/support/bin/static.py?page=known_issues.cs)
- Inbox refreshing issues (they don't receive new emails automatically)
- Some users report it is much slower than 1.0 on older machines
Comment 10 David Kilzer (:ddkilzer) 2007-12-14 07:58:14 PST
(In reply to comment #6)
> Oh, i see many apologies, this is for people who are forcing gmail1 :-/
> 
> Yes this is an evangelism issue.

Changing to Evangelism component.

Comment 11 Alexey Proskuryakov 2008-02-11 22:58:17 PST
*** Bug 17315 has been marked as a duplicate of this bug. ***
Comment 12 Ruben Bakker 2008-02-18 23:24:14 PST
The bug now appears in the latest Safari 3.1 beta release (build 9B4014).
Comment 13 Alexey Proskuryakov 2008-02-21 23:26:35 PST
*** Bug 17476 has been marked as a duplicate of this bug. ***
Comment 14 Alexey Proskuryakov 2008-02-26 09:10:54 PST
*** Bug 17527 has been marked as a duplicate of this bug. ***
Comment 15 Ashwin 2008-02-27 07:36:26 PST
I just saw that gmail has been updated and this bug does not appear with the new version. It still happens with the "Older Version" though. Thanks!
Comment 16 mitz 2008-02-28 08:17:13 PST
*** Bug 17591 has been marked as a duplicate of this bug. ***
Comment 17 Matt Lilek 2008-03-07 07:12:20 PST
*** Bug 17704 has been marked as a duplicate of this bug. ***
Comment 18 Robert Blaut 2008-03-18 09:31:52 PDT
*** Bug 17711 has been marked as a duplicate of this bug. ***
Comment 19 Robert Blaut 2008-03-18 09:57:03 PDT
*** Bug 17914 has been marked as a duplicate of this bug. ***
Comment 20 Adam Roben (:aroben) 2008-03-19 08:40:06 PDT
*** Bug 17950 has been marked as a duplicate of this bug. ***
Comment 21 Norman Williams 2008-03-19 08:52:19 PDT
This applies only to Mac Safari 3.1. The Windows Safari 3.1 worked fine with GMail 1.0
Comment 22 Gerald Cornish 2008-03-19 16:52:53 PDT
This occurs in Tiger 10.4.11 also. On reply to a googlemail message the shift key causes focus to move to subject line using webkit, safari 3.1, sunrise 1.6.5, shiira. In opera the focus moves to the first text field in the message being replied to. 
I have been updating to the latest build nightly. 
This is important for me as I do not have access to gmail 2. 
My User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/526.1+ (KHTML, like Gecko) Version/3.1 Safari/525.13
Gerry Cornish <geraldcornish@googlemail.com>
Comment 23 Oliver Hunt 2008-03-19 18:05:27 PDT
This is a bug in Google's GMail code.  You should be able work around it through the (admittedly not ideal) method of turning off rich text input.

There is nothing we can do to fix this without breaking other sites that are expecting standards compliant behaviour, and obviously we can't fix gmail ourselves :(
Comment 24 Norman Williams 2008-03-20 04:28:06 PDT
But the Windows version of Safari 3.1 worked fine for GMail 1.0. It must be Mac version bug.
Comment 25 Robert Blaut 2008-03-20 05:05:31 PDT
Confirmed as PlatformOnly bug.
Comment 26 Alexey Proskuryakov 2008-03-20 07:52:34 PDT
(In reply to comment #24)
> But the Windows version of Safari 3.1 worked fine for GMail 1.0. It must be Mac
> version bug.

Since Mac and Windows versions of Safari behave the same in this regard, this would be a platform dependency in Google code (they definitely have checks for the OS).
Comment 27 Oliver Hunt 2008-03-20 11:45:14 PDT
Could any of you with access to windows tell me whether gmail is providing you with rich text mail composition?
Comment 28 Norman Williams 2008-03-20 12:12:19 PDT
I ran the Windows version of Safari 3.1 and went to GMail web site (I am forced to use 1.0 version due to corporate email requirements).

I composed email and am able to create colorful email with no focus jumping issue found in Mac.

Perhaps just Mac Safari browser have issue with it rather than GMail?
Comment 29 Gerald Cornish 2008-03-21 11:09:45 PDT
This problem does NOT occur on my Pismo (10.4.11) when using Firefox 3beta, Netscape 7.02, Navigator 9.0.0.6, Omniweb 5.6, iCab 3.0.5, iCab 4.0.1
Comment 30 Oliver Hunt 2008-03-21 12:04:01 PDT
I will try to say this again -- the bug is in gmails code, they sniff the browser in someway that leads them to creating some absurd behavioural choice.  The bug is in gmail.  If you want to get it fixed you need to convince google to fix their code.
Comment 31 Oliver Hunt 2008-03-23 03:53:19 PDT
This used to be present on windows as well, looks like something changed on the gmail end which fixed it on webkit/win, but exposed a bug in webkit/mac *sigh*

The mac bug is fixed on trunk.
Comment 32 Robert Blaut 2008-03-23 09:47:00 PDT
(In reply to comment #31)
> The mac bug is fixed on trunk.
> 

In http://trac.webkit.org/projects/webkit/changeset/31236
Comment 33 Robert Blaut 2008-07-30 04:45:55 PDT
*** Bug 18140 has been marked as a duplicate of this bug. ***