Bug 179781 - LayoutTest http/tests/inspector/network/har/har-page.html is a flaky failure
Summary: LayoutTest http/tests/inspector/network/har/har-page.html is a flaky failure
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 179173 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-16 09:51 PST by Ryan Haddad
Modified: 2017-11-20 16:13 PST (History)
6 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (3.20 KB, patch)
2017-11-17 12:01 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-11-16 09:51:45 PST
LayoutTest http/tests/inspector/network/har/har-page.html is a flaky failure

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK2%20(Tests)/r224920%20(5780)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Finspector%2Fnetwork%2Fhar%2Fhar-page.html

--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/inspector/network/har/har-page-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/inspector/network/har/har-page-actual.txt
@@ -70,7 +70,7 @@
         "request": {
           "method": "GET",
           "url": "http://127.0.0.1:8000/inspector/resources/inspector-test.js",
-          "httpVersion": "",
+          "httpVersion": "HTTP/1.1",
           "cookies": [],
           "headers": "<filtered>",
           "queryString": [],
@@ -80,11 +80,11 @@
         "response": {
           "status": 200,
           "statusText": "OK",
-          "httpVersion": "",
+          "httpVersion": "HTTP/1.1",
           "cookies": [],
           "headers": "<filtered>",
           "content": {
-            "size": 0,
+            "size": 6707,
             "compression": 0,
             "mimeType": "application/x-javascript",
             "text": "<filtered text (6707)>"
Comment 1 Brian Burg 2017-11-16 20:48:44 PST
Thanks Ryan. Joe should take a look when he's back in.
Comment 2 Joseph Pecoraro 2017-11-17 11:08:33 PST
We can just filter out this value. I'll make that change now.
Comment 3 Joseph Pecoraro 2017-11-17 12:01:55 PST
Created attachment 327209 [details]
[PATCH] Proposed Fix
Comment 4 Alexey Proskuryakov 2017-11-17 12:10:49 PST
Comment on attachment 327209 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=327209&action=review

r=me on filtering, but I don't understand why the size changes.

> LayoutTests/http/tests/inspector/network/har/har-page-expected.txt:46
> -            "size": 2915,
> +            "size": 3042,

I don't understand this part.
Comment 5 Joseph Pecoraro 2017-11-17 12:12:05 PST
> > LayoutTests/http/tests/inspector/network/har/har-page-expected.txt:46
> > -            "size": 2915,
> > +            "size": 3042,
> 
> I don't understand this part.

That is the size of the test page itself.
Comment 6 WebKit Commit Bot 2017-11-17 12:43:15 PST
Comment on attachment 327209 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 327209

Committed r224979: <https://trac.webkit.org/changeset/224979>
Comment 7 WebKit Commit Bot 2017-11-17 12:43:16 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2017-11-17 12:44:35 PST
<rdar://problem/35621576>
Comment 9 Michael Catanzaro 2017-11-20 16:13:18 PST
*** Bug 179173 has been marked as a duplicate of this bug. ***