Bug 177060 - Make display: contents text children inherit from their parent element, not the parent renderer.
Summary: Make display: contents text children inherit from their parent element, not t...
Status: RESOLVED DUPLICATE of bug 178332
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 157477
  Show dependency treegraph
 
Reported: 2017-09-17 15:53 PDT by Emilio Cobos Álvarez [:emilio]
Modified: 2017-11-13 15:36 PST (History)
4 users (show)

See Also:


Attachments
Patch (18.49 KB, patch)
2017-09-17 18:49 PDT, Emilio Cobos Álvarez [:emilio]
no flags Details | Formatted Diff | Diff
Patch (18.22 KB, patch)
2017-09-17 18:57 PDT, Emilio Cobos Álvarez [:emilio]
no flags Details | Formatted Diff | Diff
Patch (20.79 KB, patch)
2017-09-17 22:55 PDT, Emilio Cobos Álvarez [:emilio]
no flags Details | Formatted Diff | Diff
Patch (20.80 KB, patch)
2017-09-18 00:24 PDT, Emilio Cobos Álvarez [:emilio]
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews116 for mac-elcapitan (2.39 MB, application/zip)
2017-09-18 01:57 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio Cobos Álvarez [:emilio] 2017-09-17 15:53:00 PDT
See https://github.com/w3c/csswg-drafts/issues/1118.

This is needed to make WebKit's display: contents implementation compatible with Chromium's and Gecko's.
Comment 1 Emilio Cobos Álvarez [:emilio] 2017-09-17 18:49:01 PDT
Created attachment 321061 [details]
Patch
Comment 2 Emilio Cobos Álvarez [:emilio] 2017-09-17 18:57:55 PDT
Created attachment 321062 [details]
Patch
Comment 3 Emilio Cobos Álvarez [:emilio] 2017-09-17 22:55:20 PDT
Created attachment 321079 [details]
Patch
Comment 4 Emilio Cobos Álvarez [:emilio] 2017-09-18 00:24:15 PDT
Created attachment 321080 [details]
Patch
Comment 5 Emilio Cobos Álvarez [:emilio] 2017-09-18 01:19:34 PDT
Gah, I can't repro the build failures on Linux... I guess I'll need to rework the patch to avoid moving RenderObject::style's definition.
Comment 6 Build Bot 2017-09-18 01:57:43 PDT
Comment on attachment 321080 [details]
Patch

Attachment 321080 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/4581293

New failing tests:
fast/shadow-dom/activate-over-slotted-content.html
fast/shadow-dom/hover-over-nested-slotted-content.html
fast/shadow-dom/click-text-inside-linked-slot.html
fast/shadow-dom/hover-over-slotted-content.html
Comment 7 Build Bot 2017-09-18 01:57:44 PDT
Created attachment 321083 [details]
Archive of layout-test-results from ews116 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews116  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 8 Michael Catanzaro 2017-09-22 07:22:08 PDT
Note all the iOS and macOS bots are failing, so it's not likely this will get a review.
Comment 9 Emilio Cobos Álvarez [:emilio] 2017-09-22 07:58:56 PDT
(In reply to Michael Catanzaro from comment #8)
> Note all the iOS and macOS bots are failing, so it's not likely this will
> get a review.

I know, release builds are failing because I moved the definition of RenderObject::style, and now there are a few translation units that can't access it.

I was able to repro the build failure on WebKitGTK release, so I just need to shuffle includes around.
Comment 10 Antti Koivisto 2017-10-16 02:28:43 PDT
Bug 178332 has a patch that takes a different approach and wraps text renderers with display:content into anonymous inline boxes with inherited style.
Comment 11 Antti Koivisto 2017-10-17 02:57:36 PDT

*** This bug has been marked as a duplicate of bug 178332 ***
Comment 12 Radar WebKit Bug Importer 2017-11-13 15:36:11 PST
<rdar://problem/35517680>