Bug 17622 - insertAdjacentHTML and insertAdjacentText are not implemented although insertAdjacentElement is.
: insertAdjacentHTML and insertAdjacentText are not implemented although insert...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: HTML DOM
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Sam Weinig
: InRadar
Depends on:
Blocks: 8947
  Show dependency treegraph
 
Reported: 2008-02-29 17:36 PST by Kevin McCullough
Modified: 2008-06-14 19:06 PDT (History)
2 users (show)

See Also:


Attachments
WIP (12.23 KB, patch)
2008-03-01 15:06 PST, Sam Weinig
no flags Details | Formatted Diff | Diff
updated with tests (25.25 KB, patch)
2008-06-14 18:24 PDT, Sam Weinig
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin McCullough 2008-02-29 17:36:30 PST
These are three IE functions that we would like to implement.  Currently we only have insertAdjacentElement but not insertAdjacentHTML or insertAdjacentText, and it just so happens that http://www.openwebware.com/products/openwysiwyg/demo.shtml checks for the existence of insertAdjacentElement and if found, assumes insertAdjacentHTML and insertAdjacentText exist too.  So the site fails because the functions are missing.
Comment 1 Kevin McCullough 2008-02-29 17:38:53 PST
<rdar://problem/5775192>
Comment 2 Mark Rowe (bdash) 2008-02-29 17:49:05 PST
*** Bug 17624 has been marked as a duplicate of this bug. ***
Comment 3 Mark Rowe (bdash) 2008-02-29 17:49:18 PST
*** Bug 17623 has been marked as a duplicate of this bug. ***
Comment 4 Sam Weinig 2008-03-01 15:06:08 PST
Created attachment 19474 [details]
WIP

This is mostly done, I just need to make some test cases.
Comment 5 Sam Weinig 2008-03-01 15:07:34 PST
I moved insertAdjacentElement into HTMLElement to match Opera and IE.
Comment 6 mitz@webkit.org 2008-03-01 15:26:58 PST
*** Bug 7633 has been marked as a duplicate of this bug. ***
Comment 7 Sam Weinig 2008-06-14 18:24:33 PDT
Created attachment 21704 [details]
updated with tests
Comment 8 Sam Weinig 2008-06-14 19:06:00 PDT
Mitz reviewed an updated version of the patch.

Fix landed in r34543.