Bug 17623 - insertAdjacentHTML and insertAdjacentText are not implemented although insertAdjacentElement is.
Summary: insertAdjacentHTML and insertAdjacentText are not implemented although insert...
Status: RESOLVED DUPLICATE of bug 17622
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Sam Weinig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-29 17:39 PST by Kevin McCullough
Modified: 2008-02-29 17:49 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin McCullough 2008-02-29 17:39:17 PST
These are three IE functions that we would like to implement.  Currently we only have insertAdjacentElement but not insertAdjacentHTML or insertAdjacentText, and it just so happens that http://www.openwebware.com/products/openwysiwyg/demo.shtml checks for the existence of insertAdjacentElement and if found, assumes insertAdjacentHTML and insertAdjacentText exist too.  So the site fails because the functions are missing.
Comment 1 Mark Rowe (bdash) 2008-02-29 17:49:18 PST

*** This bug has been marked as a duplicate of 17622 ***