Bug 175924 - Add support for RegExp "dotAll" flag
Summary: Add support for RegExp "dotAll" flag
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Michael Saboff
URL:
Keywords: InRadar
: 172634 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-23 20:57 PDT by Michael Saboff
Modified: 2017-09-26 12:26 PDT (History)
7 users (show)

See Also:


Attachments
Patch (40.38 KB, patch)
2017-08-24 13:05 PDT, Michael Saboff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Saboff 2017-08-23 20:57:25 PDT
This is to add support for the ECMAScript proposed Regular Expression s (dotAll) flag.  See https://github.com/tc39/proposal-regexp-dotall-flag for details.
Comment 1 Michael Saboff 2017-08-23 20:57:53 PDT
<rdar://problem/33324894>
Comment 2 Michael Saboff 2017-08-24 13:05:42 PDT
Created attachment 319014 [details]
Patch
Comment 3 Keith Miller 2017-08-24 13:27:31 PDT
Comment on attachment 319014 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=319014&action=review

r=me.

> Source/JavaScriptCore/bytecode/BytecodeDumper.cpp:-263
> -    if (regExp->sticky())

Why'd you move sticky out of curiosity?
Comment 4 Michael Saboff 2017-08-24 13:34:13 PDT
(In reply to Keith Miller from comment #3)
> Comment on attachment 319014 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=319014&action=review
> 
> r=me.
> 
> > Source/JavaScriptCore/bytecode/BytecodeDumper.cpp:-263
> > -    if (regExp->sticky())
> 
> Why'd you move sticky out of curiosity?

To alphabetize the option letters since the function is creating of those letters.
Comment 5 WebKit Commit Bot 2017-08-24 14:14:47 PDT
Comment on attachment 319014 [details]
Patch

Clearing flags on attachment: 319014

Committed r221160: <http://trac.webkit.org/changeset/221160>
Comment 6 WebKit Commit Bot 2017-08-24 14:14:49 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Michael Saboff 2017-09-26 12:26:27 PDT
*** Bug 172634 has been marked as a duplicate of this bug. ***