Bug 172634 - Implement RegExp `s` (`dotAll`) flag
Summary: Implement RegExp `s` (`dotAll`) flag
Status: RESOLVED DUPLICATE of bug 175924
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-05-25 23:47 PDT by Mathias Bynens
Modified: 2017-09-26 12:26 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Bynens 2017-05-25 23:47:06 PDT
This proposal is currently at stage 3 and seeking implementations. https://github.com/tc39/proposal-regexp-dotall-flag

Test262 files under the `regexp-dotall` features flag:

* test/annexB/built-ins/RegExp/prototype/flags/order-after-compile.js
* test/built-ins/RegExp/dotall/with-dotall-unicode.js
* test/built-ins/RegExp/dotall/with-dotall.js
* test/built-ins/RegExp/duplicate-flags.js
* test/built-ins/RegExp/prototype/dotAll/length.js
* test/built-ins/RegExp/prototype/dotAll/name.js
* test/built-ins/RegExp/prototype/dotAll/prop-desc.js
* test/built-ins/RegExp/prototype/dotAll/this-val-invalid-obj.js
* test/built-ins/RegExp/prototype/dotAll/this-val-non-obj.js
* test/built-ins/RegExp/prototype/dotAll/this-val-regexp-prototype.js
* test/built-ins/RegExp/prototype/dotAll/this-val-regexp.js
* test/built-ins/RegExp/prototype/flags/order.js
* test/built-ins/RegExp/prototype/flags/s.js
Comment 1 Radar WebKit Bug Importer 2017-05-26 17:14:24 PDT
<rdar://problem/32437595>
Comment 2 Mathias Bynens 2017-09-26 10:19:09 PDT
Per https://developer.apple.com/safari/technology-preview/release-notes/, it seems this can be closed. Any links to the relevant patch?
Comment 3 Michael Saboff 2017-09-26 12:26:27 PDT
This has already been implemented.  See https://bugs.webkit.org/show_bug.cgi?id=175924

*** This bug has been marked as a duplicate of bug 175924 ***