Created attachment 314564 [details] Patch This is a follow-up of bug 174097. It seems we can move most of the logic to ScrollingTreeScrollingNodeDelegate. I'm attaching a patch doing that. ScrollingTreeOverflowScrollingNodeIOS::commitStateBeforeChildren could be simplified a bit more if ScrolledContentsLayer was on the ScrollingStateScrollingNode.
Created attachment 314572 [details] 174134+174097+174130.patch
Created attachment 314574 [details] Patch This patch applies on top of bugs 174134 and 174097.
Created attachment 316539 [details] Patch Rebasing... This patch still applies after bug 174097.
Created attachment 317241 [details] Patch Rebasing...
<rdar://problem/34215520>
Created attachment 319856 [details] Patch
Created attachment 319891 [details] Patch
Created attachment 320011 [details] Patch
Comment on attachment 320011 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=320011&action=review > Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.h:63 > + void commitStateBeforeChildren(const WebCore::ScrollingStateScrollingNode& scrollingStateNode); > + void commitStateAfterChildren(const WebCore::ScrollingStateScrollingNode& scrollingStateNode); No need to name scrollingStateNode. > Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.h:66 > + void setScrollLayerPosition(const WebCore::FloatPoint& scrollPosition); No need to name scrollPosition > Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.h:73 > bool m_updatingFromStateNode; { false } > Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.mm:177 > + m_scrollViewDelegate = adoptNS([[WKScrollingNodeScrollViewDelegate alloc] initWithScrollingTreeNodeDelegate:this]); I wonder if this class could also be the WKScrollingNodeScrollViewDelegate, but that could be done later.
Created attachment 320162 [details] Patch for landing
Comment on attachment 320162 [details] Patch for landing Clearing flags on attachment: 320162 Committed r221753: <http://trac.webkit.org/changeset/221753>
All reviewed patches have been landed. Closing bug.
Comment on attachment 320011 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=320011&action=review >> Source/WebKit/UIProcess/RemoteLayerTree/ios/ScrollingTreeScrollingNodeDelegateIOS.mm:177 >> + m_scrollViewDelegate = adoptNS([[WKScrollingNodeScrollViewDelegate alloc] initWithScrollingTreeNodeDelegate:this]); > > I wonder if this class could also be the WKScrollingNodeScrollViewDelegate, but that could be done later. I'm not sure I understand this comment. WKScrollingNodeScrollViewDelegate is an objective-C object while ScrollingTreeScrollingNodeDelegateIOS is a C++, and I don't know how we can "merge" the two together?
Oh right, never mind :)