Bug 173704 - [iOS] Do not flatten frames when async frame scrolling is enabled
Summary: [iOS] Do not flatten frames when async frame scrolling is enabled
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Frédéric Wang (:fredw)
URL:
Keywords: InRadar
Depends on: 171914
Blocks: 149264
  Show dependency treegraph
 
Reported: 2017-06-22 02:30 PDT by Frédéric Wang (:fredw)
Modified: 2017-10-11 00:55 PDT (History)
3 users (show)

See Also:


Attachments
Patch (12.38 KB, patch)
2017-06-22 02:45 PDT, Frédéric Wang (:fredw)
no flags Details | Formatted Diff | Diff
Patch (12.43 KB, patch)
2017-09-27 02:23 PDT, Frédéric Wang (:fredw)
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2017-06-22 02:30:50 PDT
This will allow developers to test async frame scrolling without to explicitly disable frame flattening.
Comment 1 Frédéric Wang (:fredw) 2017-06-22 02:45:56 PDT
Created attachment 313604 [details]
Patch
Comment 2 Frédéric Wang (:fredw) 2017-09-27 01:48:39 PDT
The patch is bit-rotten. It seems that the new iOS simulator exposes experimental features which make this more interesting now. Maybe we can just completely disable frame flattening instead of just enabling the heuristics?
Comment 3 Frédéric Wang (:fredw) 2017-09-27 02:23:19 PDT
Created attachment 321946 [details]
Patch
Comment 4 Simon Fraser (smfr) 2017-10-10 13:04:52 PDT
Comment on attachment 321946 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=321946&action=review

> Source/WebCore/page/Settings.cpp:427
> +FrameFlattening Settings::actualFrameFlattening()

This is a very confusing name. Maybe "effectiveFrameFlattening" would be slightly less confusing?
Comment 5 Frédéric Wang (:fredw) 2017-10-11 00:49:33 PDT
(In reply to Simon Fraser (smfr) from comment #4)
> This is a very confusing name. Maybe "effectiveFrameFlattening" would be
> slightly less confusing?

OK, I'll change it.
Comment 6 Frédéric Wang (:fredw) 2017-10-11 00:54:44 PDT
Committed r223169: <http://trac.webkit.org/changeset/223169>
Comment 7 Radar WebKit Bug Importer 2017-10-11 00:55:09 PDT
<rdar://problem/34928725>