We are currently using "webkitgtk" in the names of DBus interfaces and object paths inside an ifdef with the idea that other ports could use their own names. However, the protocol is the same, so we could use the same names and make all glib based ports compatible to each other. This way we could use the GTK+ MiniBrowser to debug WPE, without having to implement the frontend part in WPE yet.
Created attachment 312067 [details]
Committed r217831: <http://trac.webkit.org/changeset/217831>