Bug 170971 - [mac-wk2] LayoutTest http/tests/inspector/network/resource-sizes-disk-cache.html is a flaky failure
Summary: [mac-wk2] LayoutTest http/tests/inspector/network/resource-sizes-disk-cache.h...
Status: RESOLVED DUPLICATE of bug 170953
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-04-18 16:36 PDT by Ryan Haddad
Modified: 2017-04-25 20:47 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-04-18 16:36:08 PDT
LayoutTest http/tests/inspector/network/resource-sizes-disk-cache.html is a flaky failure

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK2%20(Tests)/r215479%20(755)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Finspector%2Fnetwork%2Fresource-sizes-disk-cache.html

--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/inspector/network/resource-sizes-disk-cache-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/inspector/network/resource-sizes-disk-cache-actual.txt
@@ -5,16 +5,36 @@
 -- Running test setup.
 -- Running test case: PossibleNetworkLoad
 -- Running test case: Resource.Size.DiskCache.Basic
-PASS: statusCode should be 200.
+FAIL: statusCode should be 200.
+    Expected: 200
+    Actual: NaN
 PASS: compressed should be false.
-PASS: responseSource should be Symbol(disk-cache).
-PASS: estimatedNetworkEncodedSize should be exactly 0 bytes.
-PASS: estimatedTotalTransferSize should be >= (encoded body size + headers).
-PASS: size should be exactly 12940 bytes.
-PASS: networkEncodedSize should be exactly 0 bytes.
-PASS: networkTotalTransferSize should be >= (encoded body size + headers).
-PASS: requestBodyTransferSize should be exactly 0 bytes.
-PASS: responseBodyTransferSize should be exactly 0 bytes.
-PASS: requestHeadersTransferSize should be empty.
-PASS: responseHeadersTransferSize should be empty.
+FAIL: responseSource should be Symbol(disk-cache).
+    Expected: Symbol(disk-cache)
+    Actual: Symbol(unknown)
+FAIL: estimatedNetworkEncodedSize should be exactly 0 bytes.
+FAIL: estimatedTotalTransferSize should be >= (encoded body size + headers).
+    Expected: greater than or equal to 0
+    Actual: NaN
+FAIL: size should be exactly 12940 bytes.
+    Expected: 12940
+    Actual: NaN
+FAIL: networkEncodedSize should be exactly 0 bytes.
+    Expected: 0
+    Actual: NaN
+FAIL: networkTotalTransferSize should be >= (encoded body size + headers).
+    Expected: greater than or equal to 0
+    Actual: NaN
+FAIL: requestBodyTransferSize should be exactly 0 bytes.
+    Expected: 0
+    Actual: NaN
+FAIL: responseBodyTransferSize should be exactly 0 bytes.
+    Expected: 0
+    Actual: NaN
+FAIL: requestHeadersTransferSize should be empty.
+    Expected: 0
+    Actual: NaN
+FAIL: responseHeadersTransferSize should be empty.
+    Expected: 0
+    Actual: NaN
Comment 1 Ryan Haddad 2017-04-18 16:36:51 PDT
Actually, this is a new test added with https://trac.webkit.org/changeset/215445/webkit.
Comment 2 Radar WebKit Bug Importer 2017-04-25 09:21:18 PDT
<rdar://problem/31813188>
Comment 3 Ryan Haddad 2017-04-25 09:37:21 PDT
Marked test as flaky in https://trac.webkit.org/changeset/215738/webkit
Comment 4 Joseph Pecoraro 2017-04-25 20:47:59 PDT
I'm attempting to addressing this in bug 170953.

*** This bug has been marked as a duplicate of bug 170953 ***