Bug 17074 - DOMImplementation.createDocumentType does not throw correct exceptions (Acid3 bug)
Summary: DOMImplementation.createDocumentType does not throw correct exceptions (Acid3...
Status: RESOLVED DUPLICATE of bug 16693
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-29 14:38 PST by Eric Seidel (no email)
Modified: 2008-02-10 13:35 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-01-29 14:38:39 PST
DOMImplementation.createDocumentType does not throw correct exceptions (Acid3 bug)

This is related to bug 16883.  Should be simple to fix, we just need good test cases.

      // test 25: test namespace checking in createDocumentType, and
      // check that exceptions that are thrown are DOMException objects
      var message = "";
      try {
        document.implementation.createDocumentType('a:', '', ''); /* doesn't contain an illegal character; is malformed */
        message = "failed to raise exception";
      } catch (e) {
        if (e.code != e.NAMESPACE_ERR)
          message = "wrong exception";
        else if (e.INVALID_ACCESS_ERR != 15)
          message = "exceptions don't have all the constants";
      }
      if (message)
        fail(message);
      return 2;
Comment 1 Eric Seidel (no email) 2008-01-29 14:56:58 PST

*** This bug has been marked as a duplicate of 16693 ***