Bug 170727 - REGRESSION(r215211): [GTK] Lots of image related tests are timing out, causing the test bot to exit early
Summary: REGRESSION(r215211): [GTK] Lots of image related tests are timing out, causin...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Miguel Gomez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-11 05:44 PDT by Miguel Gomez
Modified: 2017-04-11 08:24 PDT (History)
4 users (show)

See Also:


Attachments
Patch (7.12 KB, patch)
2017-04-11 06:12 PDT, Miguel Gomez
cgarcia: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Gomez 2017-04-11 05:44:42 PDT
r215211 changed ImageDecoder::isSizeAvailable() to call encodedDataStatus() in the subclasses, which forces a partial decoding of the image to get the size from the file. But ImageDecoder::isSizeAvailable() is also being called inside the decoders in some places. One of this places is the setSize() method inside each decoder. So a call to isSizeAvailable() when the image size is not known causes the image to be partially decoded to get the size, but as a result setSize() gets called, which calls isSizeAvailable() again, which triggers a new decoder because the size has not been set, and we have another infinte loop.
Comment 1 Miguel Gomez 2017-04-11 06:12:50 PDT
Created attachment 306808 [details]
Patch
Comment 2 Carlos Garcia Campos 2017-04-11 06:16:10 PDT
Comment on attachment 306808 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=306808&action=review

> Source/WebCore/ChangeLog:3
> +        REGRESSION(r215211): [GTK] Lots of image related tests are timign out, causing the test bot to exit early

Fix the typo. timign -> timing
Comment 3 Miguel Gomez 2017-04-11 06:19:27 PDT
Committed r215227: <http://trac.webkit.org/changeset/215227>