Bug 170028 - webkitpy should be able to run API tests
Summary: webkitpy should be able to run API tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 170021
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-23 15:40 PDT by Srinivasan Vijayaraghavan
Modified: 2019-04-05 20:46 PDT (History)
7 users (show)

See Also:


Attachments
Patch (5.60 KB, patch)
2017-03-23 15:43 PDT, Srinivasan Vijayaraghavan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Srinivasan Vijayaraghavan 2017-03-23 15:40:06 PDT
webkitpy should be able to run API tests
Comment 1 Srinivasan Vijayaraghavan 2017-03-23 15:43:49 PDT
Created attachment 305233 [details]
Patch
Comment 2 Sam Weinig 2017-03-24 05:37:15 PDT
I don't understand why this is necessary? The api tests script is perl script, why involve another language?
Comment 3 Alexey Proskuryakov 2017-03-24 09:00:32 PDT
It's to run API tests in EWS, which is all written in Python.
Comment 4 Alexey Proskuryakov 2017-03-24 11:50:17 PDT
Comment on attachment 305233 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=305233&action=review

> Tools/Scripts/webkitpy/tool/steps/runtests.py:65
> +        if self._options.group == "api":

I'm not sure if this is quite right. As API tests run together with regular ones, marking the EWS queue as "api" doesn't seem to make sense.
Comment 5 Srinivasan Vijayaraghavan 2017-03-24 12:17:49 PDT
(In reply to Alexey Proskuryakov from comment #4)
> Comment on attachment 305233 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=305233&action=review
> 
> > Tools/Scripts/webkitpy/tool/steps/runtests.py:65
> > +        if self._options.group == "api":
> 
> I'm not sure if this is quite right. As API tests run together with regular
> ones, marking the EWS queue as "api" doesn't seem to make sense.

This code runs when webkit-patch calls itself using a command such as "webkit-patch build-and-test --test --non-interactive --group=x". What's being checked here is the value of x that was passed, not any property of the queue itself.

The arguments above are generated in PatchAnalysisTask, which will be changed to allow group=api for running the API tests.
Comment 6 Srinivasan Vijayaraghavan 2017-03-24 12:22:54 PDT
They won't always run together with the layout tests, for example if only one of them needs to be re-tested. So, we need a way to run them independently. The code in EarlyWarningSystem, EarlyWarningSystemTask etc would then decide whether to run both (default), or just one.
Comment 7 WebKit Commit Bot 2017-03-24 14:24:02 PDT
Comment on attachment 305233 [details]
Patch

Clearing flags on attachment: 305233

Committed r214377: <http://trac.webkit.org/changeset/214377>
Comment 8 WebKit Commit Bot 2017-03-24 14:24:06 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Daniel Bates 2019-04-05 14:28:03 PDT
*** Bug 106596 has been marked as a duplicate of this bug. ***