Bug 169882 - WebAssembly: allocate no more than 4GiB for Signaling memory
Summary: WebAssembly: allocate no more than 4GiB for Signaling memory
Status: RESOLVED DUPLICATE of bug 170628
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 159775
  Show dependency treegraph
 
Reported: 2017-03-20 11:19 PDT by JF Bastien
Modified: 2017-04-07 17:13 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JF Bastien 2017-03-20 11:19:33 PDT
We currently virtually allocate 8GiB because odd corner cases potentially allow accesses to go above 4GiB. Those would always trap, so we need the memory to be mapped. This lowers the number of "fast" signaling memory we can allocate, it would be better to figure out which accesses could go above 4GiB, bounds check those, and all the other ones can stay entirely unchecked.

Note: maybe we want 4GiB + some small redzone for small offsets.
Comment 1 JF Bastien 2017-04-07 17:13:38 PDT

*** This bug has been marked as a duplicate of bug 170628 ***