Bug 168891 - Expand font matching algorithm for preinstalled fonts to include variation axis ranges
Summary: Expand font matching algorithm for preinstalled fonts to include variation ax...
Status: RESOLVED DUPLICATE of bug 168893
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords:
Depends on:
Blocks: 162815
  Show dependency treegraph
 
Reported: 2017-02-26 21:18 PST by Myles C. Maxfield
Modified: 2017-03-06 18:56 PST (History)
2 users (show)

See Also:


Attachments
WIP (8.40 KB, patch)
2017-03-06 17:33 PST, Myles C. Maxfield
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2017-02-26 21:18:14 PST
Currently, the font matching algorithm operates on individual values, when it should operate on ranges.

https://bugs.webkit.org/show_bug.cgi?id=168678 creates the infrastructure for this, but the variation ranges from Core Text need to be consulted.
Comment 1 Myles C. Maxfield 2017-03-06 17:33:49 PST
Created attachment 303591 [details]
WIP
Comment 2 WebKit Commit Bot 2017-03-06 17:35:50 PST
Attachment 303591 [details] did not pass style-queue:


ERROR: Source/WebCore/ChangeLog:8:  You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible.  [changelog/nonewtests] [5]
Total errors found: 1 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Myles C. Maxfield 2017-03-06 18:56:42 PST
Will be done in https://bugs.webkit.org/show_bug.cgi?id=168893

*** This bug has been marked as a duplicate of bug 168893 ***