Bug 167275 - LayoutTest media/modern-media-controls/tracks-support/tracks-support-show-panel-after-dragging-controls.html is flaky
Summary: LayoutTest media/modern-media-controls/tracks-support/tracks-support-show-pan...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-01-20 18:13 PST by Ryan Haddad
Modified: 2017-03-03 05:06 PST (History)
3 users (show)

See Also:


Attachments
Patch (3.27 KB, patch)
2017-02-07 05:32 PST, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (7.15 KB, patch)
2017-03-02 21:10 PST, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (7.35 KB, patch)
2017-03-02 21:14 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-01-20 18:13:46 PST
LayoutTet media/modern-media-controls/tracks-support/tracks-support-show-panel-after-dragging-controls.html is flaky

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK1%20(Tests)/r211004%20(2990)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fmodern-media-controls%2Ftracks-support%2Ftracks-support-show-panel-after-dragging-controls.html

--- /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/media/modern-media-controls/tracks-support/tracks-support-show-panel-after-dragging-controls-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/media/modern-media-controls/tracks-support/tracks-support-show-panel-after-dragging-controls-actual.txt
@@ -3,7 +3,7 @@
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS shadowRoot.querySelector('button.tracks').getBoundingClientRect().right === shadowRoot.querySelector('.tracks-panel').getBoundingClientRect().right is true
+FAIL shadowRoot.querySelector('button.tracks').getBoundingClientRect().right === shadowRoot.querySelector('.tracks-panel').getBoundingClientRect().right should be true. Was false.
 PASS shadowRoot.querySelector('.tracks-panel').style.bottom is "151px"
 
 PASS successfullyParsed is true
Comment 1 Ryan Haddad 2017-01-23 12:56:55 PST
Marked test as flaky in http://trac.webkit.org/projects/webkit/changeset/211051
Comment 2 Antoine Quint 2017-02-03 02:02:59 PST
Can't reproduce the failure on Sierra WK1 Release with a single runner replicating the failed worker at https://build.webkit.org/builders/Apple%20Sierra%20Release%20WK1%20(Tests)/builds/3351.
Comment 3 Antoine Quint 2017-02-07 04:35:48 PST
So this is failing now as a result of the fix for https://bugs.webkit.org/show_bug.cgi?id=167875. I know how to fix this.
Comment 4 Antoine Quint 2017-02-07 05:32:56 PST
Created attachment 300805 [details]
Patch
Comment 5 WebKit Commit Bot 2017-02-07 06:09:19 PST
Comment on attachment 300805 [details]
Patch

Clearing flags on attachment: 300805

Committed r211806: <http://trac.webkit.org/changeset/211806>
Comment 6 WebKit Commit Bot 2017-02-07 06:09:23 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Ryan Haddad 2017-02-07 13:57:47 PST
Reopening because this test is still flaky.

https://build.webkit.org/results/Apple%20El%20Capitan%20Release%20WK1%20(Tests)/r211833%20(13493)/results.html
Comment 8 Ryan Haddad 2017-02-07 14:31:56 PST
Marked test as flaky again in http://trac.webkit.org/projects/webkit/changeset/211839
Comment 9 Radar WebKit Bug Importer 2017-03-02 20:22:56 PST
<rdar://problem/30824290>
Comment 10 Antoine Quint 2017-03-02 21:10:21 PST
Created attachment 303298 [details]
Patch
Comment 11 Antoine Quint 2017-03-02 21:14:54 PST
Created attachment 303300 [details]
Patch
Comment 12 WebKit Commit Bot 2017-03-03 05:06:41 PST
Comment on attachment 303300 [details]
Patch

Clearing flags on attachment: 303300

Committed r213364: <http://trac.webkit.org/changeset/213364>
Comment 13 WebKit Commit Bot 2017-03-03 05:06:45 PST
All reviewed patches have been landed.  Closing bug.