Bug 166689 - stress/spread-calling.js timing out on the bots
Summary: stress/spread-calling.js timing out on the bots
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords: InRadar
: 165770 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-04 11:21 PST by Saam Barati
Modified: 2017-01-04 13:32 PST (History)
14 users (show)

See Also:


Attachments
patch (1.17 KB, patch)
2017-01-04 11:29 PST, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2017-01-04 11:21:58 PST
I'm going to make the test run for fewer iterations. The timeout is not catching a real bug, it's just slow under the eager compilation mode. I tried bumping the iteration count much higher, and ran under eager compilation, and the test completes just fine after a few minutes.
Comment 1 Saam Barati 2017-01-04 11:23:56 PST
<rdar://problem/29779182>
Comment 2 Saam Barati 2017-01-04 11:29:33 PST
Created attachment 298032 [details]
patch
Comment 3 Mark Lam 2017-01-04 11:30:07 PST
Comment on attachment 298032 [details]
patch

rs=me
Comment 4 Alexey Proskuryakov 2017-01-04 13:12:03 PST
*** Bug 165770 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Commit Bot 2017-01-04 13:32:47 PST
Comment on attachment 298032 [details]
patch

Clearing flags on attachment: 298032

Committed r210285: <http://trac.webkit.org/changeset/210285>
Comment 6 WebKit Commit Bot 2017-01-04 13:32:51 PST
All reviewed patches have been landed.  Closing bug.