Bug 165770 - REGRESSION (r209710?): JSC Stress test stress/spread-calling.js.ftl-eager-no-cjit timing out
Summary: REGRESSION (r209710?): JSC Stress test stress/spread-calling.js.ftl-eager-no-...
Status: RESOLVED DUPLICATE of bug 166689
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-12-12 13:03 PST by Ryan Haddad
Modified: 2017-01-04 13:12 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-12-12 13:03:42 PST
JSC Stress test stress/spread-calling.js.ftl-eager-no-cjit timing out

https://build.webkit.org/builders/Apple%20Yosemite%20Release%20JSC%20%28Tests%29/builds/16477

stress/spread-calling.js.ftl-eager-no-cjit: Timed out after 339.000000 sec seconds!
stress/spread-calling.js.ftl-eager-no-cjit: test_script_16271: line 2: 61700 Trace/BPT trap: 5       ( "$@" ../../.vm/JavaScriptCore.framework/Resources/jsc --useFTLJIT\=false --useFunctionDotArguments\=true --maxPerThreadStackUsage\=1572864 --validateGraph\=true --useFTLJIT\=true --useConcurrentJIT\=false --thresholdForJITAfterWarmUp\=100 --scribbleFreeCells\=true --thresholdForJITAfterWarmUp\=10 --thresholdForJITSoon\=10 --thresholdForOptimizeAfterWarmUp\=20 --thresholdForOptimizeAfterLongWarmUp\=20 --thresholdForOptimizeSoon\=20 --thresholdForFTLOptimizeAfterWarmUp\=20 --thresholdForFTLOptimizeSoon\=20 --maximumEvalCacheableSourceLength\=150000 --useEagerCodeBlockJettisonTiming\=true --collectContinuously\=true --useGenerationalGC\=false spread-calling.js )
stress/spread-calling.js.ftl-eager-no-cjit: ERROR: Unexpected exit code: 133
FAIL: stress/spread-calling.js.ftl-eager-no-cjit
Comment 1 Ryan Haddad 2016-12-12 13:04:49 PST
This is seen on the Yosemite Release JSC bot.
Comment 2 Ryan Haddad 2016-12-12 13:27:18 PST
The only JSC change in the failing run was https://trac.webkit.org/changeset/209710
Comment 3 Ryan Haddad 2016-12-12 13:28:22 PST
(In reply to comment #1)
> This is seen on the Yosemite Release JSC bot.

One instance seen on El Capitan Release here, so perhaps this is a flaky timeout:

https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20JSC%20(Tests)?numbuilds=50
Comment 4 Filip Pizlo 2016-12-12 14:42:49 PST
(In reply to comment #3)
> (In reply to comment #1)
> > This is seen on the Yosemite Release JSC bot.
> 
> One instance seen on El Capitan Release here, so perhaps this is a flaky
> timeout:
> 
> https://build.webkit.org/builders/
> Apple%20El%20Capitan%20Release%20JSC%20(Tests)?numbuilds=50

I'm on it...
Comment 5 Alexey Proskuryakov 2016-12-16 10:37:39 PST
Just happened on the first run of Sierra Release tester too, FWIW.
Comment 6 Radar WebKit Bug Importer 2016-12-20 12:30:16 PST
<rdar://problem/29758371>
Comment 7 Alexey Proskuryakov 2017-01-04 12:56:25 PST
Does bug 166689 have a complete fix for this, or is there something else that needs to be done?
Comment 8 Saam Barati 2017-01-04 13:09:32 PST
(In reply to comment #7)
> Does bug 166689 have a complete fix for this, or is there something else
> that needs to be done?

I believe all that's needed is to make the test run for less time. So bug 166689 should be sufficient.
Comment 9 Alexey Proskuryakov 2017-01-04 13:12:03 PST

*** This bug has been marked as a duplicate of bug 166689 ***