Bug 163963 - WebAssembly JS API: simple Module test
Summary: WebAssembly JS API: simple Module test
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: JF Bastien
URL:
Keywords:
Depends on: 163959
Blocks: 161709
  Show dependency treegraph
 
Reported: 2016-10-25 12:25 PDT by JF Bastien
Modified: 2016-10-25 16:53 PDT (History)
3 users (show)

See Also:


Attachments
patch (2.36 KB, patch)
2016-10-25 12:28 PDT, JF Bastien
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description JF Bastien 2016-10-25 12:25:16 PDT
Add a simple Module test.
Comment 1 JF Bastien 2016-10-25 12:28:04 PDT
Created attachment 292800 [details]
patch

Note dependency on https://bugs.webkit.org/show_bug.cgi?id=163959
Comment 2 JF Bastien 2016-10-25 14:26:03 PDT
Comment on attachment 292800 [details]
patch

Dependency landed, this can go in as well.
Comment 3 WebKit Commit Bot 2016-10-25 14:51:08 PDT
Comment on attachment 292800 [details]
patch

Clearing flags on attachment: 292800

Committed r207846: <http://trac.webkit.org/changeset/207846>
Comment 4 WebKit Commit Bot 2016-10-25 14:51:13 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Michael Catanzaro 2016-10-25 16:43:55 PDT
Hi, this test is failing for GTK+ and I'm not sure how to handle it as I don't normally work with JavaScript tests. Can you please look at bug #163846?
Comment 6 JF Bastien 2016-10-25 16:53:46 PDT
(In reply to comment #5)
> Hi, this test is failing for GTK+ and I'm not sure how to handle it as I
> don't normally work with JavaScript tests. Can you please look at bug
> #163846?

Sorry about that, I replied on the bug. Let's discuss there, I think a prior patch is what causes the issue you're seeing.