Another step for bug 160543.
MathMLInlineContainerElement sounds a bad name for something that is now going to produce RenderMathMLBlocks. At the moment most of the presentation MathML elements are actually MathMLInlineContainerElement and I believe most of the code of MathMLElement could be moved in that derived class. A MathMLUnknownElement class could be introduced for unknown elements, following what is done in SVG or HTML classes.
Created attachment 286614 [details]
Created attachment 286691 [details]
Created attachment 286695 [details]
Comment on attachment 286695 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=286695&action=review
It'd be nice to add the explanation of the rename here and not only in the bug comments.
Committed r204809: <http://trac.webkit.org/changeset/204809>