Bug 160448 - Skip fetch API worker tests in Debug mode
Summary: Skip fetch API worker tests in Debug mode
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-02 05:09 PDT by youenn fablet
Modified: 2016-08-03 22:39 PDT (History)
2 users (show)

See Also:


Attachments
Patch for landing (5.86 KB, patch)
2016-08-02 05:17 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2016-08-02 05:09:28 PDT
They are crashing sometimes (see bug 160444)
Comment 1 youenn fablet 2016-08-02 05:17:03 PDT
Created attachment 285100 [details]
Patch for landing
Comment 2 WebKit Commit Bot 2016-08-02 05:46:23 PDT
Comment on attachment 285100 [details]
Patch for landing

Clearing flags on attachment: 285100

Committed r204023: <http://trac.webkit.org/changeset/204023>
Comment 3 WebKit Commit Bot 2016-08-02 05:46:26 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Alexey Proskuryakov 2016-08-03 16:38:12 PDT
What is the plan to fix the crashes? Is there a bug tracking that?
Comment 5 youenn fablet 2016-08-03 22:39:08 PDT
(In reply to comment #4)
> What is the plan to fix the crashes? Is there a bug tracking that?

Bug 160444 and bug 160498 are fixing the most common debug crashes issues.
I plan to reactivate the worker tests after these ones and watch the bots.

There was also bug 156737 but I am not able to reproduce it anymore.
It may have been fixed.