Bug 159465 - [GTK][Threaded Compositor] Web view background colors don't work
Summary: [GTK][Threaded Compositor] Web view background colors don't work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 159455
Blocks: 154066
  Show dependency treegraph
 
Reported: 2016-07-06 05:31 PDT by Carlos Garcia Campos
Modified: 2016-07-21 00:26 PDT (History)
3 users (show)

See Also:


Attachments
Patch (6.71 KB, patch)
2016-07-07 03:36 PDT, Carlos Garcia Campos
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2016-07-06 05:31:23 PDT
Bug #159455 makes them work for GTK+ when not using the threaded compositor, but it's not enough for the threaded compositor.
Comment 1 Carlos Garcia Campos 2016-07-07 03:36:14 PDT
Created attachment 283004 [details]
Patch
Comment 2 Michael Catanzaro 2016-07-20 17:30:00 PDT
Comment on attachment 283004 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=283004&action=review

> Source/WebKit2/Shared/CoordinatedGraphics/threadedcompositor/ThreadedCompositor.cpp:87
> +        m_drawsBackground = drawsBackground;

This is fine as it is, but my style is to capture only protectedThis and use it explicitly in the lambda, instead of capturing both this and protectedThis. I'm not sure which style is more prevalent in WebKit code.
Comment 3 Carlos Garcia Campos 2016-07-21 00:21:39 PDT
(In reply to comment #2)
> Comment on attachment 283004 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=283004&action=review
> 
> > Source/WebKit2/Shared/CoordinatedGraphics/threadedcompositor/ThreadedCompositor.cpp:87
> > +        m_drawsBackground = drawsBackground;
> 
> This is fine as it is, but my style is to capture only protectedThis and use
> it explicitly in the lambda, instead of capturing both this and
> protectedThis. I'm not sure which style is more prevalent in WebKit code.

There's no consensus last time we discussed it, some people (like me) prefer to also capture this to make the lambda body easier to read without having to use protectedThis-> everywhere.
Comment 4 Carlos Garcia Campos 2016-07-21 00:26:33 PDT
Committed r203497: <http://trac.webkit.org/changeset/203497>