Bug 157447 - Rename HitTestRequest DisallowShadowContent to DisallowUserAgentShadowContent
Summary: Rename HitTestRequest DisallowShadowContent to DisallowUserAgentShadowContent
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joseph Pecoraro
Depends on:
Reported: 2016-05-06 21:54 PDT by Joseph Pecoraro
Modified: 2016-05-06 23:03 PDT (History)
4 users (show)

See Also:

[PATCH] Proposed Fix (32.33 KB, patch)
2016-05-06 21:56 PDT, Joseph Pecoraro
rniwa: review+
joepeck: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2016-05-06 21:54:58 PDT
Rename HitTestRequest DisallowShadowContent to DisallowUserAgentShadowContent.

See diagnosis in patch on bug 157446. HitTesting is intended to reach nodes inside Web Components shadow content. This property on the HitTestRequest is intended to avoid hit testing in UserAgent shadow content. Lets rename the enum value, and cascading methods for clarity.
Comment 1 Joseph Pecoraro 2016-05-06 21:56:08 PDT
Created attachment 278317 [details]
[PATCH] Proposed Fix
Comment 2 Joseph Pecoraro 2016-05-06 21:57:08 PDT
cq- there is one instance in WebKitAdditions that I'll want to change at the same time.
Comment 3 Joseph Pecoraro 2016-05-06 21:57:40 PDT
And this probably won't apply until bug 157446 lands anyways.
Comment 4 Ryosuke Niwa 2016-05-06 22:10:37 PDT
Comment on attachment 278317 [details]
[PATCH] Proposed Fix

r=me assuming you add some change log description.
Comment 5 Joseph Pecoraro 2016-05-06 23:03:56 PDT