Bug 15739 - [Transforms] Selection smears on animated transform
Summary: [Transforms] Selection smears on animated transform
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P2 Minor
Assignee: Simon Fraser (smfr)
URL:
Keywords:
Depends on: 21942 22472
Blocks: 15670
  Show dependency treegraph
 
Reported: 2007-10-28 16:03 PDT by Maxwell Terpstra
Modified: 2008-12-06 17:04 PST (History)
2 users (show)

See Also:


Attachments
Testcase that works fine (1.12 KB, text/html)
2008-11-20 18:04 PST, Simon Fraser (smfr)
no flags Details
testcase with rotating replaced content (955 bytes, text/html)
2008-11-21 00:17 PST, Maxwell Terpstra
no flags Details
Testcase for selection on transformed image (685 bytes, text/html)
2008-11-21 09:00 PST, Simon Fraser (smfr)
no flags Details
Patch, testcase, changelog (5.66 KB, patch)
2008-12-06 16:56 PST, Simon Fraser (smfr)
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maxwell Terpstra 2007-10-28 16:03:08 PDT
Sample URL pulled from blog comments.

If the rotating graphic is selected, a selection highlight "smears" around the edges as it rotates.
Comment 1 Simon Fraser (smfr) 2008-11-20 16:36:16 PST
Testcase (http://picknewtemplate.blogspot.com/2007/10/webkit-gets-element-transforms.html) has gone away.
Comment 2 Simon Fraser (smfr) 2008-11-20 18:04:52 PST
Created attachment 25327 [details]
Testcase that works fine
Comment 3 Simon Fraser (smfr) 2008-11-20 18:05:14 PST
Marking WorksForMe based on testcase.
Comment 4 Maxwell Terpstra 2008-11-21 00:17:57 PST
Created attachment 25343 [details]
testcase with rotating replaced content

Shows selection smearing in Webkit r38592
Comment 5 Maxwell Terpstra 2008-11-21 00:19:21 PST
The bug only happens when replaced content is rotated -- see new attached test-case.
Comment 6 Simon Fraser (smfr) 2008-11-21 09:00:07 PST
Thanks for the testcase; it reproduced in TOT.

It actually looks like the selection rendering for the replaced element is wrong as soon as the replace element gets a transform. Testcase coming.
Comment 7 Simon Fraser (smfr) 2008-11-21 09:00:56 PST
Created attachment 25355 [details]
Testcase for selection on transformed image
Comment 8 Simon Fraser (smfr) 2008-12-06 16:56:40 PST
Created attachment 25824 [details]
Patch, testcase, changelog
Comment 9 Simon Fraser (smfr) 2008-12-06 17:04:07 PST
r39072 = 0e9a7ee0d9d8eee03464f6aa301ba2000ab089ca (trunk)
	M	WebCore/ChangeLog
	M	WebCore/rendering/RenderReplaced.cpp
	A	LayoutTests/platform/mac/fast/replaced/selection-rect-transform-expected.png
	A	LayoutTests/platform/mac/fast/replaced/selection-rect-transform-expected.txt
	A	LayoutTests/platform/mac/fast/replaced/selection-rect-transform-expected.checksum
	M	LayoutTests/ChangeLog
	A	LayoutTests/fast/replaced/selection-rect-transform.html
r39073 = 41705c6dcf11fb008cdba307fcdc8648d2b5badf (trunk)