Bug 156094 - [WinCairo] Sometimes WebCore/PlatformExportMacros.h not found
Summary: [WinCairo] Sometimes WebCore/PlatformExportMacros.h not found
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-31 18:43 PDT by Bill Ming
Modified: 2016-03-31 20:23 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.81 KB, patch)
2016-03-31 18:57 PDT, Bill Ming
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Ming 2016-03-31 18:43:34 PDT
[383/3385] Building CXX object Tools\TestWebKitAPI\CMakeFiles\TestWTFLib.dir\TestsController.cpp.obj
FAILED: C:\PROGRA~2\MICROS~1.0\VC\bin\amd64\cl.exe   /nologo /TP -DBUILDING_WITH_CMAKE=1 -DGTEST_HAS_RTTI=0 -DGTEST_LINKED_AS_SHARED_LIBRARY=0 -DHAVE_CONFIG_H=1 -DNOMINMAX -DTEST_INJECTED_BUNDLE_PATH=\"\" -DTEST_WEBKIT2_RESOURCES_DIR=\"C:/Dev/webkit-git/Tools/TestWebKitAPI/Tests/WebKit2\" -DTestWTFLib_EXPORTS -DUNICODE -DUSE_CONSOLE_ENTRY_POINT -DWEBCORE_EXPORT="" -DWINVER=0x601 -DWIN_CAIRO -DWTF_PLATFORM_WIN_CAIRO=1 -D_CRT_SECURE_CPP_OVERLOAD_STANDARD_NAMES=1 -D_CRT_SECURE_NO_WARNINGS -D_HAS_EXCEPTIONS=0 -D_UNICODE -D_WINDOWS -IDerivedSources\ForwardingHeaders -IDerivedSources -I..\..\WebKitLibraries\win\include -IDerivedSources\ForwardingHeaders\JavaScriptCore -I..\..\Tools\TestWebKitAPI\win -IDerivedSources\WebKit\Interfaces -I..\..\Tools\TestWebKitAPI -I. -I..\..\Source -IDerivedSources\JavaScriptCore -IDerivedSources\WebCore -I..\..\Source\JavaScriptCore -I..\..\Source\JavaScriptCore\API -I..\..\Source\JavaScriptCore\ForwardingHeaders -I..\..\Source\ThirdParty\gtest\include -I..\..\Source\WebCore\css -I..\..\Source\WebCore\dom -I..\..\Source\WebCore\editing -I..\..\Source\WebCore\loader\cache -I..\..\Source\WebCore\platform -I..\..\Source\WebCore\platform\animation -I..\..\Source\WebCore\platform\graphics -I..\..\Source\WebCore\platform\text -I..\..\Source\WebCore\platform\network -I..\..\Source\WebCore\platform\network\soup -I..\..\Source\WebCore\rendering\style -I..\..\Source\WebKit2\Platform\IPC -I..\..\Source\WebKit2\Shared -I..\..\Source\WebKit2\Shared\API -I..\..\Source\WebKit2\Shared\API\c -I..\..\Source\WebKit2\Shared\Plugins -I..\..\Source\WebKit2\UIProcess -I..\..\Source\WebKit2\UIProcess\API -I..\..\Source\WebKit2\WebProcess\InjectedBundle -I..\..\Source\WebKit2\WebProcess\InjectedBundle\API\c -I..\..\Source\WTF /DWIN32 /D_WINDOWS /W4 /GR- /EHs- /EHc-  /MT /O2 /Ob2 /D NDEBUG   /wd4018 /wd4068 /wd4099 /wd4100 /wd4127 /wd4138 /wd4146 /wd4180 /wd4189 /wd4201 /wd4244 /wd4251 /wd4267 /wd4275 /wd4288 /wd4291 /wd4305 /wd4309 /wd4344 /wd4355 /wd4389 /wd4396 /wd4456 /wd4457 /wd4458 /wd4459 /wd4481 /wd4503 /wd4505 /wd4510 /wd4512 /wd4530 /wd4610 /wd4611 /wd4702 /wd4706 /wd4800 /wd4819 /wd4951 /wd4952 /wd4996 /wd6011 /wd6031 /wd6211 /wd6246 /wd6255 /wd6387 /Zi /GS /EHa- /EHc- /EHs- /fp:except- /analyze- /bigobj /Gy- /openmp- /GF- /Oy- /showIncludes /FoTools\TestWebKitAPI\CMakeFiles\TestWTFLib.dir\TestsController.cpp.obj /FdTools\TestWebKitAPI\CMakeFiles\TestWTFLib.dir\ /FS -c ..\..\Tools\TestWebKitAPI\TestsController.cpp

The issue is much similar to what happened in webkitgtk port:
https://bugs.webkit.org/show_bug.cgi?id=148379
https://bugs.webkit.org/show_bug.cgi?id=137207
Comment 1 Bill Ming 2016-03-31 18:57:13 PDT
Created attachment 275367 [details]
Patch
Comment 2 Alex Christensen 2016-03-31 19:32:10 PDT
Thanks!
Comment 3 WebKit Commit Bot 2016-03-31 20:22:59 PDT
Comment on attachment 275367 [details]
Patch

Clearing flags on attachment: 275367

Committed r198938: <http://trac.webkit.org/changeset/198938>
Comment 4 WebKit Commit Bot 2016-03-31 20:23:03 PDT
All reviewed patches have been landed.  Closing bug.