Bug 155276 - [ios-sim debug] API test WTF_Lock.ContendedShortSection and WTF_ParkingLot.UnparkOneFifty timing out
Summary: [ios-sim debug] API test WTF_Lock.ContendedShortSection and WTF_ParkingLot.Un...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
: 153997 155345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-09 15:54 PST by Ryan Haddad
Modified: 2016-03-11 15:56 PST (History)
2 users (show)

See Also:


Attachments
proposed fix (2.17 KB, patch)
2016-03-11 15:48 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-03-09 15:54:13 PST
[ios-sim debug] API test WTF_Lock.ContendedShortSection and WTF_ParkingLot.UnparkOneFifty timing out

These tests has been timing out since the debug testbots were brought up. WTF_ParkingLot.UnparkOneFifty seems to be a flaky timeout.

<https://build.webkit.org/builders/Apple%20iOS%209%20Simulator%20Debug%20WK2%20(Tests)/builds/99/steps/run-api-tests/logs/stdio>
Comment 1 Alexey Proskuryakov 2016-03-11 15:48:16 PST
Created attachment 273780 [details]
proposed fix
Comment 2 Alexey Proskuryakov 2016-03-11 15:48:48 PST
*** Bug 153997 has been marked as a duplicate of this bug. ***
Comment 3 Alexey Proskuryakov 2016-03-11 15:49:03 PST
*** Bug 155345 has been marked as a duplicate of this bug. ***
Comment 4 Alexey Proskuryakov 2016-03-11 15:55:35 PST
Comment on attachment 273780 [details]
proposed fix

Filip rubber-stamped the patch.
Comment 5 Alexey Proskuryakov 2016-03-11 15:56:17 PST
Committed http://trac.webkit.org/r198053