Bug 154052 - 3 WKUserContentController API tests failing after r196341
Summary: 3 WKUserContentController API tests failing after r196341
Status: RESOLVED DUPLICATE of bug 154046
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-09 15:43 PST by Ryan Haddad
Modified: 2016-02-09 17:12 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-02-09 15:43:33 PST
3 WKUserContentController API tests failing after r196341

Tests that failed:
  WKUserContentController.AddUserStyleSheetBeforeCreatingView
  WKUserContentController.UserStyleSheetAffectingAllFrames
  WKUserContentController.UserStyleSheetAffectingOnlyMainFrame

<https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK2%20%28Tests%29/builds/3215>

FAIL WKUserContentController.AddUserStyleSheetBeforeCreatingView

/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKit2Cocoa/UserContentController.mm:276
Value of: value
  Actual: "rgb(255, 0, 0)"
Expected: color
Which is: "rgb(0, 128, 0)"

FAIL WKUserContentController.UserStyleSheetAffectingAllFrames

/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKit2Cocoa/UserContentController.mm:276
Value of: value
  Actual: "rgb(255, 0, 0)"
Expected: color
Which is: "rgb(0, 128, 0)"


/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKit2Cocoa/UserContentController.mm:276
Value of: value
  Actual: "rgba(0, 0, 0, 0)"
Expected: color
Which is: "rgb(0, 128, 0)"

FAIL WKUserContentController.UserStyleSheetAffectingOnlyMainFrame

/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKit2Cocoa/UserContentController.mm:276
Value of: value
  Actual: "rgb(255, 0, 0)"
Expected: color
Which is: "rgb(0, 128, 0)"
Comment 1 Ryan Haddad 2016-02-09 17:12:12 PST
Duping to original bug for the change since it was rolled out.

*** This bug has been marked as a duplicate of bug 154046 ***