Bug 15399 - Compilation of JavaScriptCore prepends the icu-config compiler flags, instead of appending them
Summary: Compilation of JavaScriptCore prepends the icu-config compiler flags, instead...
Status: RESOLVED DUPLICATE of bug 15400
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-06 07:34 PDT by Ed Schouten
Modified: 2007-10-06 07:37 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Schouten 2007-10-06 07:34:40 PDT
Compilation of WebKit fails on my desktop, because cxxflags of icu-config are prepended, instead of appended. This causes stuff like pcre.h to be included from /usr/local/include, instead of the one shipped with WebKit.

An example:

c++ -c -pipe -D_REENTRANT -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -W -DBUILDING_GTK__ -I/usr/local/share/qt4/mkspecs/freebsd-g++ -I../../../../JavaScriptCore/kjs -I../../../../JavaScriptCore -I../../../../JavaScriptCore/kjs -I../../../../JavaScriptCore/bindings -I../../../../JavaScriptCore/bindings/c -I../../../../JavaScriptCore/wtf -Itmp -I../../../../JavaScriptCore -I../../../../JavaScriptCore/kjs -I../../../../JavaScriptCore/bindings -I../../../../JavaScriptCore/bindings/c -I../../../../JavaScriptCore/wtf -I../../../../JavaScriptCore/pcre -Itmp -I../../../../JavaScriptCore/kjs -I/usr/local/include -I. -o internal.o ../../../../JavaScriptCore/kjs/internal.cpp
Comment 1 Ed Schouten 2007-10-06 07:37:43 PDT
Sorry. I thought I didn't press the Commit button hard enough.

*** This bug has been marked as a duplicate of 15400 ***