Bug 152785 - [mips] Add missing branchAdd32 implementation in macro assembler
Summary: [mips] Add missing branchAdd32 implementation in macro assembler
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 145247 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-06 04:24 PST by Julien Brianceau
Modified: 2016-01-16 03:25 PST (History)
7 users (show)

See Also:


Attachments
Add missing branchAdd32 implementation in mips macro assembler (1.34 KB, patch)
2016-01-06 04:26 PST, Julien Brianceau
msaboff: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Brianceau 2016-01-06 04:24:01 PST
In mips macro assembler, branchAdd32(ResultCondition cond, Address src, RegisterID dest) implementation is missing.
Comment 1 Julien Brianceau 2016-01-06 04:26:33 PST
Created attachment 268366 [details]
Add missing branchAdd32 implementation in mips macro assembler

Note: already contributed in qtwekbit http://code.qt.io/cgit/qt/qtwebkit.git/commit/?id=946088cf515ec30de586392ec72e4658b86650a4
Comment 2 Michael Saboff 2016-01-06 09:44:55 PST
Comment on attachment 268366 [details]
Add missing branchAdd32 implementation in mips macro assembler

r=me
Comment 3 Julien Brianceau 2016-01-06 12:57:05 PST
Manually committed r194639: http://trac.webkit.org/changeset/194639
Comment 4 Julien Brianceau 2016-01-16 03:25:21 PST
*** Bug 145247 has been marked as a duplicate of this bug. ***