Bug 145247 - [MIPS] webkitgtk fails to build for MIPS platform
Summary: [MIPS] webkitgtk fails to build for MIPS platform
Status: RESOLVED DUPLICATE of bug 152785
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-21 02:00 PDT by Jeffrey
Modified: 2016-01-18 19:31 PST (History)
5 users (show)

See Also:


Attachments
Patch for MIPS platform build error! (1.56 KB, patch)
2015-05-21 02:11 PDT, Jeffrey
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey 2015-05-21 02:00:54 PDT
Build fails on MIPS because the following function is missing from MacroAssemblerMIPS.h:

        Jump branchAdd32(ResultCondition cond, Address src, RegisterID dest)
Comment 1 Jeffrey 2015-05-21 02:11:55 PDT
Created attachment 253510 [details]
Patch for MIPS platform build error!
Comment 2 Csaba Osztrogonác 2015-05-22 04:46:29 PDT
Comment on attachment 253510 [details]
Patch for MIPS platform build error!

I assume you would like to ask review for it, so set r? and patch flag too.
Comment 3 WebKit Commit Bot 2015-05-22 04:48:16 PDT
Attachment 253510 [details] did not pass style-queue:


Total errors found: 0 in 0 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Jeffrey 2015-05-24 19:24:52 PDT
Made a mistake to resolve the issue.
Comment 5 Michael Catanzaro 2015-12-30 15:21:46 PST
Guillaume, this look OK? You didn't run into this issue...?
Comment 6 Julien Brianceau 2016-01-16 03:25:21 PST

*** This bug has been marked as a duplicate of bug 152785 ***
Comment 7 Guillaume Emont 2016-01-18 18:43:14 PST
(In reply to comment #5)
> Guillaume, this look OK? You didn't run into this issue...?

Yes I ran into this issue and had  made a fix I hadn't submitted yet (wasn't certain it was correct yet). I think we are 3 people who have solved it the same way independently. Anyway, it's fixed in trunk now with Julien's patch.
Comment 8 Michael Catanzaro 2016-01-18 19:31:51 PST
Comment on attachment 253510 [details]
Patch for MIPS platform build error!

Unsetting the flags then (stupid WebKit Bugzilla shows the patch in request-queue forever if you forget to do this).