Bug 151691 - AX: Change the AXRoleDescription value of the ARIA feed role to "feed"
Summary: AX: Change the AXRoleDescription value of the ARIA feed role to "feed"
Status: RESOLVED DUPLICATE of bug 171183
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: Safari 9
Hardware: All All
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-11-30 18:51 PST by James Craig
Modified: 2017-04-30 06:33 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Craig 2015-11-30 18:51:23 PST
ARIA 1.1 adds a new type of list subclass called "feed" with "article" children. Articles are not landmarks, but it might be useful to have some quick navigation between them when in a "feed" context.

http://rawgit.com/w3c/aria/master/aria/aria.html#feed
Comment 1 Radar WebKit Bug Importer 2015-11-30 18:51:41 PST
<rdar://problem/23699399>
Comment 2 James Craig 2015-11-30 18:57:17 PST
That said, I haven't seen a convincing argument for why a list of articles in a "feed" is more or less useful than a list of articles outside a "feed"
Comment 3 James Craig 2015-12-04 01:56:38 PST
Looks like the general consensus is that people just want article navigation separate from the main landmarks, so let's just add a Safari rotor for <article> and role="article".

This would allow quick rotor navigation on many sites like Facebook, Twitter, etc. w/o the need for a new container role.
Comment 4 Zoë Bijl 2015-12-04 02:28:28 PST
Before Feed gets shot down completely, please consider that we might want to expand it to support other elements/media like images, video, or even mixed.

See PFWG minutes here: http://www.w3.org/2015/11/12-aria-minutes.html#item04
Comment 5 James Craig 2015-12-04 04:05:07 PST
Isn't "list" sufficient for those?
Comment 6 Zoë Bijl 2015-12-24 10:38:30 PST
@James: I think you're better off asking Matt King, he came up with it :)
Comment 7 Rich Schwerdtfeger 2016-11-01 12:58:43 PDT
 I would recommend you do the same mapping we created (Mac terms) for feed. Group would suffice, as you can have a group of articles, if you don’t wish to do anything special. IA2 uses a group role with an xml-roles object attribute=“feed”. So, this would be as simple as having an AXGroup role with a Mac role description of  “feed”.
Comment 8 James Craig 2017-04-29 16:41:00 PDT
Adoption of this has been reasonable in sites and other rendering engines, so let's implement. 

Todo: Implement a new 'feedRole' in WebKit, a with macOS platform mapping of:

  AXRole: AXGroup
  AXSubrole: AXApplicationGroup
  AXRoleDescription: 'feed'
Comment 9 Joanmarie Diggs (irc: joanie) 2017-04-29 18:50:45 PDT
(In reply to James Craig from comment #8)
> Adoption of this has been reasonable in sites and other rendering engines,
> so let's implement. 
> 
> Todo: Implement a new 'feedRole' in WebKit, a with macOS platform mapping of:
> 
>   AXRole: AXGroup
>   AXSubrole: AXApplicationGroup

The above is already done.

>   AXRoleDescription: 'feed'

This will need to be done. Currently it is 'group'. Assigning to myself. Will do a new patch, along with some other new roles, tomorrow.

Thanks for the update!
Comment 10 Joanmarie Diggs (irc: joanie) 2017-04-30 06:33:57 PDT
Closing as a dup of bug 171183 which now has a patch which adds the figure and term roles and also updates the AXRoleDescription mapping for the feed role.

*** This bug has been marked as a duplicate of bug 171183 ***