The regular expression we use to match resource domains to cookie domains only allows for one subdomain, apparently:
static cookieDomainMatchesResourceDomain(cookieDomain, resourceDomain)
if (cookieDomain.charAt(0) !== ".")
return resourceDomain === cookieDomain;
return !!resourceDomain.match(new RegExp("^([^\\.]+\\.)?" + cookieDomain.substring(1).escapeForRegExp() + "$"), "i");
To test this, we should move the logic into a model class static method. Come to think of it, this code is stupidly structured and blocks live updates by making the view responsible for fetching cookies. But let's take this a step at a time...
Created attachment 265817 [details]
This patch won't apply, as it depends on the other patch that moves the code.
Committed r192615: <http://trac.webkit.org/changeset/192615>